View Full Version : [ubuntu] Lost Windows Xp

February 21st, 2009, 07:51 AM

I've tried to clean install latest ubuntu on a Win XP installed machine
side by side. After the installation Ubuntu's Grub didn't see the win xp, so it directly started from ubuntu providing menu without win xp boot option.

Then I decided to install Fedora's latest version to take back my win xp. Because I've had such a problem with Fedora, and it sees the win xp on the parallel. After a successful installation of fedora, I tried to boot win xp from fedora's grub (it's seen as "Other" on Fedora's grub), but it didn't boot win xp and it said "GRUB >" on a black screen without accepting any keystrokes on the screen.

I think Ubuntu's installation did something onwin xp's mbr. I have all my stuff on win xp partitition and it can't be seen from fedora right know. I'll be really glad if you can provie some solution.

Kaind Regards,


February 21st, 2009, 02:59 PM
In order to get a clearer picture of your setup, how about downloading the Boot Info Script to your Fedora desktop:


Then open a terminal (Applications > Accessories > Terminal) and do the following (but replace <username> with your user name):

su -
bash /home/<username>/Desktop/boot_info_script*.sh
That will create a "RESULTS.txt" file in the same directory from where the script is run, namely your desktop; please copy/paste the contents of the RESULTS.txt file to your next post, highlight the copied text, and click the pound/hash sign "#" graphic button in the Ubuntu forum message box so that the text will get "code" tags put around it. The results of that script will help clarify your setup.

February 21st, 2009, 05:53 PM
Below is from RESULT.TXT of boot_info_script.sh, and it says that Grub is installed in the boot sector of sda1. I think it should have said somethnig about MBR of Windows XP. But how can I fix this?

============================= Boot Info Summary: ==============================

=> Grub0.97 is installed in the MBR of /dev/sda and looks at sector 76085880
on boot drive #1 for the stage2 file. A stage2 file is at this location on
/dev/sda. Stage2 looks on partition #2 for /boot/grub/grub.conf.

sda1: __________________________________________________ _______________________

File system:
Boot sector type: Grub
Boot sector info: Grub is installed in the boot sector of sda1 and looks
at sector 75528887 of the same hard drive for the
stage2 file, but no stage2 files can be found at this
Mounting failed:
mount: unknown filesystem type ''

sda2: __________________________________________________ _______________________

File system: ext3
Boot sector type: -
Boot sector info:
Operating System: Fedora release 10 (Cambridge)
Kernel on an ()
Boot files/dirs: /boot/grub/menu.lst /boot/grub/grub.conf /etc/fstab

sda3: __________________________________________________ _______________________

File system: swap
Boot sector type: Unknown
Boot sector info:

=========================== Drive/Partition Info: =============================

Drive sda: __________________________________________________ ___________________

Disk /dev/sda: 40.0 GB, 40007761920 bytes
255 heads, 63 sectors/track, 4864 cylinders, total 78140160 sectors
Units = sectors of 1 * 512 = 512 bytes
Disk identifier: 0xd64cd64c

Partition Boot Start End Size Id System

/dev/sda1 * 63 67,730,039 67,729,977 7 HPFS/NTFS
/dev/sda2 67,730,040 76,951,349 9,221,310 83 Linux
/dev/sda3 76,951,350 78,140,159 1,188,810 82 Linux swap / Solaris

blkid -c /dev/null: __________________________________________________ __________

/dev/sda2: LABEL="/" UUID="5536aaeb-56c1-4464-ab51-0b056c45fc0d" TYPE="ext3"
/dev/sda3: LABEL="SWAP-sda3" UUID="2de0f397-a44f-4133-a035-5919b0ca9b7c" TYPE="swap"

=============================== "mount" output: ===============================

/dev/sda2 on / type ext3 (rw)
/proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)

========================== sda2/boot/grub/grub.conf: ==========================

# grub.conf generated by anaconda
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You do not have a /boot partition. This means that
# all kernel and initrd paths are relative to /, eg.
# root (hd0,1)
# kernel /boot/vmlinuz-version ro root=/dev/sda2
# initrd /boot/initrd-version.img
title Fedora (
root (hd0,1)
kernel /boot/vmlinuz- ro root=UUID=5536aaeb-56c1-4464-ab51-0b056c45fc0d rhgb quiet
initrd /boot/initrd-
title Fedora (
root (hd0,1)
kernel /boot/vmlinuz- ro root=UUID=5536aaeb-56c1-4464-ab51-0b056c45fc0d rhgb quiet
initrd /boot/initrd-
title Other
rootnoverify (hd0,0)
chainloader +1

=============================== sda2/etc/fstab: ===============================

# /etc/fstab
# Created by anaconda on Sat Feb 21 03:24:45 2009
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or vol_id(8) for more info
UUID=5536aaeb-56c1-4464-ab51-0b056c45fc0d / ext3 defaults 1 1
tmpfs /dev/shm tmpfs defaults 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
sysfs /sys sysfs defaults 0 0
proc /proc proc defaults 0 0
UUID=2de0f397-a44f-4133-a035-5919b0ca9b7c swap swap defaults 0 0

=================== sda2: Location of files loaded by Grub: ===================

35.1GB: boot/grub/grub.conf
35.1GB: boot/grub/menu.lst
38.9GB: boot/grub/stage2
37.4GB: boot/initrd-
37.6GB: boot/initrd-
36.5GB: boot/vmlinuz-
36.8GB: boot/vmlinuz-
=========================== Unknown MBRs/Boot Sectors/etc =======================

Unknown BootLoader on sda3

00000000 00 78 30 30 00 78 30 30 00 78 30 30 00 78 30 30 |.x00.x00.x00.x00|

February 21st, 2009, 05:58 PM
It looks like when you installed Ubuntu, you accidentally chose "/dev/sda1", or your Windows partition boot sector, as the location to install Grub to. To fix it, how about booting your Windows Install CD, go to the "recovery console" and do:

That should hopefully be all it takes so you can boot Windows again, but let me know how it goes.

February 21st, 2009, 06:05 PM
I got some info from the forum. I think while installing Ubuntu, I chose "/dev/sda1" where Win Xp is installed instead of sda2 to install GRUB. As a result, I destroyed my win xp boot.ini and the other result is I cannot mount/read win xp partition (hd0) on Fedora. If I cannot see win xp partition from Fedora, how can I fix it? Besides I have no idea about how to fix the boot.ini of win xp. I'd appriciate if can suggest some howto. Thanks.

PS: Thank you for your swift reply, I'll try it.

February 21st, 2009, 08:16 PM
Yeah!! Thank you very much, it works smoothly now.

February 21st, 2009, 08:21 PM
Glad to hear that worked OK; cheers and enjoy your dual-boot setup.