View Full Version : [ubuntu] Grub error 15

February 21st, 2009, 01:51 AM
Crash bang boom.
I turned on my computer today and I get

GRUB Loading Stage 1.5
GRUB loading, please wait.
Error 15

And I can't get anything to show up by pressing keys on the keyboard. I put in an Ubuntu live CD and select "boot/install", only to get

SQUASHFS error: Unable to read fragment cache block [27e431eb]
SQUASHFS error: Unable to read page, block 27e431eb, size a87c
SQUASHFS error: sb_bread failed reading block 0x9f936

There is also a series of numbers on the left counting higher constantly.

What is going on? Is this a HDD problem or an Ubuntu problem?

February 21st, 2009, 02:10 AM
Check your drive/partitions with TestDisk:

February 21st, 2009, 02:20 AM

February 21st, 2009, 03:39 AM
Thanks Pumalite for the expedient response! :D

I looked at what you suggested, but sadly, I had no success with either... :(

Check your drive/partitions with TestDisk:
I couldn't do this because I can't boot to anything, HDD or CD.

I downloaded a Super Grub Disc img and RawWrote it onto a floppy. I then booted to the floppy and I get:

GRUB Loading stage2......Read Error_
Do I just have a bad HDD?

February 21st, 2009, 11:06 AM
It looks like.Do a memtest and check the cables.

February 21st, 2009, 11:44 AM
Is there a way to run Memtest without booting to GRUB?

February 21st, 2009, 05:25 PM
I had this same issue when I first tried to install ubuntu on my big machine.
Grub was installing on the wrong hard drive even though I chose the correct one during install, it has something to do with the way Bios reads the HDDs vs. the way ubuntu reads them.

I had three HDDs one had windows, the other had Linux and the third was just for storage.
I installed ubuntu many times and always got the same error.
Finally I unplugged my storage drive and installed one more time and it worked. when I plugged the storage drive back in everything was fine.

March 5th, 2009, 01:00 AM

I've tried everything I could think of. I even brought it to school to get it checked out.
No luck.

It looks like the drive is a goner. :(

Anyway, thanks for everybody's help! :D
I'd rather know that its not fixable than not know and have it sitting there.

The Ubuntu community will always be better than my hardware. :lol: