View Full Version : [ubuntu] virtual box not working after last upgrade

February 17th, 2009, 07:53 AM

today i have done the latest updated which included kernel
and virtualbox updated to after reboot i am trying to start a
VM and i get :

Failed to open/create the internal network 'HostInterfaceNetworking-eth0' (VERR_SUPDRV_COMPONENT_NOT_FOUND).
Failed to attach the network LUN (VERR_SUPDRV_COMPONENT_NOT_FOUND).
Unknown error creating VM (VERR_SUPDRV_COMPONENT_NOT_FOUND).

on all my VMs does anybody else have the same problem and maybe a solution???

by the way i am on ubuntu 8.10 x64 machine.

February 17th, 2009, 07:59 AM
ok i seem to have solved my own problem for some reason the vboxdrv module didn't recompile automatically so after doing a sudo /etc/init.d/vboxdrv setup everything seems fine.

February 17th, 2009, 08:50 AM
I think that is normal behaviour from virtualbox when you upgrade the kernel.

I also _think_ this will happen automaticaly if you install dkms

sudo apt-get install dkms

but I have not tried it...

I will upgrade my kernel now and see if it works!

February 17th, 2009, 09:10 AM
I just upgraded my kernel, and dkms did it's stuff! Virtualbox VMs was working fine after a reboot, just as i expected!

I just hadn't upgraded my kernel after I installed Virtualbox so I was not sure if dkms would work with it. Upgrading took a while longer, but it saves you some stress!

February 18th, 2009, 10:59 PM
Same problem here.
Probably kernel has to be updated first, hard reset Ubuntu and then upgrade Virtualbox!
I did both in one task and networking failed to work unit I run sudo /etc/init.d/vboxdrv setup and restarted networking or the whole Ubuntu.

February 18th, 2009, 11:21 PM
From VirtualBox download page: http://www.virtualbox.org/wiki/Linux_Downloads

Note: Ubuntu users might want to install the dkms package (not available on Debian) to ensure that the VirtualBox host kernel modules (vboxdrv and vboxnetflt) are properly updated if the linux kernel version changes during the next apt-get upgrade.

If you don't install dkms (before a kernel upgrade), you will have to run

sudo /etc/init.d/vboxdrv setup

January 18th, 2010, 12:52 AM
What might help you is a simple

$ sudo apt-get remove virtualbox-ose-guest-source
before executing

$ sudo /etc/init.d/vboxdrv setup

Use it at your own discretion.

March 6th, 2011, 09:33 PM
What might help you is a simple

$ sudo apt-get remove virtualbox-ose-guest-sourcebefore executing

$ sudo /etc/init.d/vboxdrv setupUse it at your own discretion.

Thanks this fixed the issue for me.

January 19th, 2012, 07:52 AM
I'm facing the same issue on a ReadyNAS Ultra 2 (Intel Atom, 2GB RAM, Debian 4). Not related to upgrade though, vm's with nat networking start fine but bridged mode doesnt work:

Error: failed to start machine. Error message: Failed to open/create the internal network 'HostInterfaceNetworking-' (VERR_INVALID_PARAMETER).
Failed to attach the network LUN (VERR_INVALID_PARAMETER)