View Full Version : [ubuntu] eMac G4 booting into single user mode

February 17th, 2009, 04:36 AM
I have tried "Linux 1" with no success. I have tried "Linux init=/bin/sh", and that works, but it mounts my filesystem as read only, I need to fix /etc/sudoers. I have also tried booting up with live CD, no success. I have tried booting up with the text mode installer, I can get to BusyBox, but then mounting my hard drive fails (no such device)


February 17th, 2009, 04:42 AM
Ok, for some reason "Linux single" works, but "Linux 1" does not.

I can get to the recovery menu, but the arrow keys do not let me select an option. How do I navigate this menu?

February 19th, 2009, 01:04 AM

February 19th, 2009, 01:22 AM
Is it a fresh install? Have you tried the Ubuntu Hardy LiveCD? You say no success? What does it mean?

February 19th, 2009, 01:36 AM
The liveCD just gives me a black screen.

There has to be some way to navigate the recovery menu. Why don't the arrow keys work? That seems like a pretty serious bug.

February 19th, 2009, 01:43 AM
Please, you should give us more infos about your hardware (ram?) and what you are trying to do. Is that a fresh install? Did you download the right Cd for PPC?
When you try to boot the Live CD, what happens? Do you try to give there video=ofonly?

February 19th, 2009, 02:13 AM
I have already installed UbuntuPPC with the text mode installer. I accidentally removed myself from the admin group (whoops!) I thought the Ubuntu installer put the first user into sudoers, I didn't realize that it relied on a group for sudo.

Anyway, all I am trying to do is boot into single user mode.

I can do this by doing "Linux single" at the yaboot prompt, but when I get to the recovery menu, it cannot be navigated. The arrow keys simply do not work. This seems to me to be a serious bug.

February 23rd, 2009, 11:04 PM

February 23rd, 2009, 11:11 PM
Sorry, I forgot to answer... I'm not sure, that it is a bug. At least, I haven't heard anything about it. Maybe you can't work in single user mode.
Anyway the easiest solution is to start from the LiveCD, giving at the yaboot prompt video=ofonly
Have you already tried it?

March 5th, 2009, 01:05 AM
Thanks, using the live CD with those commands worked!

However, that bug with the recovery menu seems liek a serious problem.