View Full Version : [ubuntu] Installing obsolete packages

February 14th, 2009, 05:12 AM
I need to use g++-3.4 (I have g++-4.3 installed currently).

apt-get says "Package g++-3.4 is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source"

What repositories must I enable to be able to install old/obsolete packages?


February 14th, 2009, 05:28 AM
It looks like it's not in the Ubuntu repositories in Ubuntu 8.10. You could try to find it on the web manually, if you need it:


That should be it. You can download it directly or add the repository for dapper, as it indicates on that page.

February 14th, 2009, 05:52 AM
Thanks. But using Synaptic didn't work for me.

I got it done manually from this thread (https://bugs.launchpad.net/ubuntu/+source/gcc-3.4/+bug/295427).

From the last post in the above thread.