View Full Version : [ubuntu] installed a new dvd rw

February 13th, 2009, 09:28 PM
i installed a new dvd rw Samsung sh202n lightscribe dual layer on a friends pc with 8.04.1 new install
the dvd does not show up in places but when i pud it a dvd i can open the dvd but when i go to play it it gives the error with totem could not open you might not have permission to open file.

February 13th, 2009, 09:31 PM
Try using a different cable to connect the drive to the motherboard & make sure that the plugs are fully inserted in to the sockets (motherboard & Drive)

February 13th, 2009, 09:35 PM
yep it does come up as a drive in computer although it does come up with no permissions.

February 13th, 2009, 09:41 PM
If there is no disk in the drive the permissions should show up as 'couldn't be determined'

February 13th, 2009, 09:46 PM
yeah i put in a dvd. which works no problem on my machine running 8.10. And the disk comes up on desktop, when i open it and click open with media player. i get the error. i also added all the dvd codex libdvdcss already. but it seems to be a permission thing.

February 13th, 2009, 09:48 PM
i don't know if this helps but it does say permission can't be determined when i click on the device in computer

February 13th, 2009, 09:55 PM
Thr CD/DVD burner on my machine shows this in fstab:

/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0

check it against your own fstab.

February 13th, 2009, 09:58 PM
Have you tried more than just the one media player?

February 13th, 2009, 10:21 PM
i don't know if this helps but it does say permission can't be determined when i click on the device in computer

Under computer ALL of my devices show the permissions as un-determined.

And until I insert some media, the optical drive does not show on my desktop or in Places.

February 13th, 2009, 10:25 PM
it does even with the media in.when i try to play it in movie player... the error comes up permissions not determined.

February 13th, 2009, 10:58 PM
With DVD's & CD's the permissions cannot be determined, with or without disk's.
This is normal.
I would try a different media player. VLC is very good.

February 14th, 2009, 02:26 AM
vlc also says it can't open the dvd in the new dvd rw player how do i check the fstab

February 14th, 2009, 02:30 AM
there is no entry for it in /etc/fstab???
i have no idea what to do now?????

February 14th, 2009, 04:30 AM
how do i make a new dvd player mount???
Doesn't it need a mount point like the cd player???????

February 17th, 2009, 09:28 PM
i apologize for posting this twice, i wasn't getting an answer so i tried to move this to the hardware and laptop forum. and while doing that i figured out how to fix it. I would have preferred to close the thread but i haven't figured out how to do that. So here is how i fixed it in case anyone faces the same problem.

i upgraded the device firmware in windows and now it works fine. teh hardware web site wouldn't let me do it on ubuntu.

February 17th, 2009, 10:53 PM
Sorry not to have posted back, but I was busy & really couldn't think of many more options.
I am afraid that manufacturers hardly ever allow upgrades to firmware from Linux, mores the pity. That might have been one option I would have suggested after trying another drive, but with it being a new device it is not always the first thing :(
Still at least you got it going :)
Good job & thanks for posting the result.

February 17th, 2009, 11:00 PM
do you have the ability to use the optical drive for data and other uses, and the core problem is with playing DVDs? (jw if it is a fault of the media rather than the drive itself)

February 18th, 2009, 10:50 PM
it all works fine now.
It was the firmware that needed updating.