PDA

View Full Version : Quanta plus i la codificaciˇ de carÓcters



kukat
February 13th, 2009, 12:29 PM
Com estic un poc rallat, a veure si m'explique.

He passat del Kompozer al Quanta Plus (ja que no m'anava el Kompozer i veig que no es veu soluciˇ a la vista) i a part d'estar molt content amb el QUanta Plus (molt efectiu i senzill!!!) sols tinc un problema...

Quan he fet avui una pÓgina, els accents no m'ixen com ho tenia configurat al Firefox ( Occidental ISO-8850-1). Clar, al canviar-lo a Unicode UTF-8, es veuen correctament...

Per˛ com ho faig per a que el QUanta Plus em faša correctament els accents? Lo normal es tindre el firefox amb Occidental, nO? ja estic rallant-me....
AJuda! :)

lluisanunez
February 13th, 2009, 07:00 PM
Lo normal (o potser diria, el millor) Ús que el Firefox llegeixi a la pÓgina la declaraciˇ de joc de caracters.
Per exemple aqui al f˛rum la pÓgina diu:

<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1" />

I a la pestanya del costat tinc una pÓgina que diu:

<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />

I totes dues es veuen la mar de bÚ, amb accents i tot.

PerquŔ les pÓgines que fas tinguin una declaraciˇ de joc de carÓcters, has d'anar a les propietats del document, o de la pÓgina (ara no tinc cap Quanta a mÓ) i establir-hi el joc de carÓcters.

kukat
February 19th, 2009, 10:19 AM
No encontre per a que es veja en els dos formats...:(

En "Tools", "Encoding", tinc assenyalat "Western European (iso-8859-1)

i en "Settings" "Configure Quanta" en "Environment" tinc a "Default CHaracter Encoding", el mateix, "iso 8859-1" i Default DTD (que no se que Ús) "HTML 4.01 Transitional".

Per cert, cada vegada que s'obri el Quanta em surt un missatge:
"Some applications required for full functionality are missing:

- KImageMapEditor [http://www.nongnu.org/kimagemap/] - editing HTML image maps will not be available;
- Cervisia [http://www.kde.org/apps/cervisia] - CVS management plugin will not be available.

You may download the applications from the specified locations."

per˛ aix˛ supose que sˇn ampliacions del programa, no crec que tinga res a veure (aix˛ va per a altre post). Que per cert, tin el Cervisia instalat i l'altre tambÚ...per˛ es veu que no ho pilla o tinc que configurar alguna cosa...


Salutacions i moltes grÓcies!

RainCT
February 19th, 2009, 05:08 PM
Comprova que al źhead╗ del codi font de la pÓgina hi hagi la segŘent lÝnia i, si no hi Ús, pots afegir-la-hi tu mateix:



<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1" />

kukat
February 19th, 2009, 10:19 PM
Doncs ja estÓ! Moltes grÓcies!!!
De vegades la soluciˇ mÚs l˛gica no se'ns ocorre...i era eixa! :p

Moltes grÓcies!