PDA

View Full Version : [gnome] How do I run a shell script without getting prompted?



rliegh
February 12th, 2009, 10:54 PM
By default, Gnome will ask you if you want to run a script in a terminal, display it, or simply run it. The very annoying thing is that Gnome does this each and every time you click on the file.

What I want is to be able to have gnome treat the shell script as a regular program; IE I double click on it, and it launches -no questions asked.

How can I get gnome to do this?:confused:

kaibob
February 13th, 2009, 02:00 AM
Load Nautilus and click on Edit > Preferences > Behavior. Then, place a check mark next to "Run executable text files when they are opened."

rliegh
February 13th, 2009, 03:53 AM
Load Nautilus and click on Edit > Preferences > Behavior. Then, place a check mark next to "Run executable text files when they are opened."

Just what I was looking for -thanks, Kaibob!