PDA

View Full Version : [ubuntu] help please



kapi
February 12th, 2009, 09:11 PM
tried opening synaptic manager and keep getting this message:

E:dpkg was interrupted, you must manually run dpkg --configure a to correct the problem

cache ->open() failed . . .please report




can anyone asists please

thanks Kapi

wolfen69
February 12th, 2009, 09:14 PM
do in terminal:

sudo dpkg --configure -a

cariboo
February 12th, 2009, 09:23 PM
This is such a common problem, that any search of google with the words dpkg --configure a, would find more answers to the question than you need. That being said, open a Applications-->Accessories-->Terminal and type:


sudo dpkg --configure a

You will be asked for your user password, when you type it in, it won't be echoed back, then hit enter.

Jim

kapi
February 12th, 2009, 09:26 PM
Hi done it but it doesnt work

craig@craig-laptop:~$ dpkg --configure -a
dpkg: requested operation requires superuser privilege
craig@craig-laptop:~$ sudo dpkg --configure -a
Processing triggers for libc6 ...
ldconfig deferred processing now taking place
dpkg: dependency problems prevent configuration of mysql-server:
mysql-server depends on mysql-server-5.0; however:
Package mysql-server-5.0 is not installed.
dpkg: error processing mysql-server (--configure):
dependency problems - leaving unconfigured
dpkg: ../../src/packages.c:221: process_queue: Assertion `dependtry <= 4' failed.
Aborted
I hope this helps

thanks

kapi

kansasnoob
February 12th, 2009, 09:34 PM
Hi done it but it doesnt work

craig@craig-laptop:~$ dpkg --configure -a
dpkg: requested operation requires superuser privilege
craig@craig-laptop:~$ sudo dpkg --configure -a
Processing triggers for libc6 ...
ldconfig deferred processing now taking place
dpkg: dependency problems prevent configuration of mysql-server:
mysql-server depends on mysql-server-5.0; however:
Package mysql-server-5.0 is not installed.
dpkg: error processing mysql-server (--configure):
dependency problems - leaving unconfigured
dpkg: ../../src/packages.c:221: process_queue: Assertion `dependtry <= 4' failed.
Aborted
I hope this helps

thanks

kapi

First try:


sudo apt-get -f install

I wonder what you installed that depends on mysql-server-5.0???? But installing that would be my next suggestion, only I'd use synaptic to watch and see what all it may install or remove to resolve dependencies.

kapi
February 12th, 2009, 09:40 PM
hi synaptic gives me that error message telling me to run dpkg configure a

also the update manager seems to want to download mysql server 5 but then fails and gives me the same dpkg configure a message

really baffled - if you can help I would be grateful indeed

Kapi

sneeks
February 12th, 2009, 09:43 PM
you need to do what it says mate,i will look for an earlier post for u

http://ubuntuforums.org/showthread.php?t=687595

kapi
February 12th, 2009, 09:45 PM
I have via the terminal, also a message has also stated that cache-> open(),failed. please report

kapi
February 12th, 2009, 11:50 PM
Thanks everyone for the help. I went to the update manager - selected check for updates then everything seemed to go Ok, except that the apache seemed not to load- will try again

thanks Kapi