PDA

View Full Version : [ubuntu] Enable the IOMMU option in BIOS setup



22moondune
February 8th, 2009, 08:58 AM
Hello,

I used to have Ubuntu 8.04 installed on my PC, but Then I installed Vista Ultimate as a secondary OS. I noticed that Linux seemed to be running slowly, so I deleted the partition in hopes of reinstalling with the newer 8.10.

When insert the Ubuntu 8.10 Disc, I get the following Message:

[0.004000] Aperture beyond 4Gb. Ignoring.
[0.004000] Your BIOS doesn't leave a aperture memory hole
[0.004000] Please enable the IOMMU option in the BIOS setup
[0.004000] This costs you 64 MB of RAM
...

There is a little more additional stuff beyond that, but I have no idea how to fix this issue. After this message it loads BusyBox, but won't boot into Linux. I found a link to another person that had a problem similar, except I don't have Ubuntu installed at all:
http://ubuntuforums.org/showthread.php?t=1018854&highlight=enable+iommu+option+bios

I really want to install Linux, but I have no idea how to solve this problem. Here is some of my hardware:

ASUS M3A32-MVP Deluxe
4Gb Corsair Memory (not sure which model)
AMD 9600 Phenom
XFX 9800 GTX Nvdida GPU

Any help would be appreciated.

MStadt84
March 14th, 2009, 01:01 AM
I'm having the same problem.
similar specs,
my error is
"Aperture pointing to e820 RAM. Ignoring.
Your BIOS doesn't leave a aperture memory hole
Please enable the IOMMU option in the BIOS setup
This costs you 64 MB of RAM"

this is a fresh install, no os existing before on this machine.
I've never used ubuntu before, anything will help
thanks