View Full Version : [ubuntu] Wireless disabled, then driver disappeared.

February 6th, 2009, 07:48 PM
Kei, so I'm an intermediate Linux user and when I first installed Ubuntu, for my wireless network card the Broadcom STA driver was found and installed (in the Proprietary Drivers manager).

So a shut down my computer with no sign of a recent update, restart it the next morning and the indicator for my wireless is amber instead of blue. This meaning that it's disabled. So I flip it a few times, inspected my wireless card (it's built-in and everything was connected properly).

So, I look around for solutions, none of which have worked. I downloaded ndiswrapper and installed my driver through there, still no effect. The wireless adapter didn't appear in the proprietary drivers manager anymore, and I also had an option for enable/disable wireless under the network icon, but it has since disappeared.

So, does anyone know a way I could restore my driver without reinstalling Ubuntu? I've got it connected to the internet via router at the moment.

System Information

Ubuntu 8.10 Intrepid Bipex
HP TX1000

Also, with iwconfig I get no wireless connections on lo, eth0, and wifi0. ^^; I haven't found a solution besides reinstallation of Ubuntu until now, and that's not really an option for me. I thank you in advance for any assistance.