PDA

View Full Version : [ubuntu] Sound controls not working on laptop



joelwhrs
February 5th, 2009, 08:25 AM
I have a dell inpirion e1505 and my volume controls on the front and on the keyboard dont work. They used to work great but then all of a sudden they just dont work. it still works as long as i adjust it manually using the volume control. and while i'm asking this i might as well ask how to get all my system sounds working correctly, everytime that i get to where a curser cant move i get this annoying beep, exactly the one that happens when windows has an error like a virus or something, scares me everytime lol:p

joelwhrs
February 6th, 2009, 07:08 PM
If it helps when I adjust the sound using the controls it will actually adjust the capture volume and not the main volume.

joelwhrs
February 9th, 2009, 05:27 PM
I just checked and the controls work if i go on another profile. PLEASE help i cant turn down that annoying beep and it happens in some programs to and i cant get it to turn off.

joelwhrs
February 14th, 2009, 04:45 PM
Please, does anybody know how to do this?? If nobody does how do i switch all my apps over to another username and just use that because it works on the other user. Please

neu2buntu
February 14th, 2009, 05:03 PM
in reference to your post #2 , have you tried right click on speaker icon > preferences > and in the "select device and track to control" section have you chosen "master" here not "capture"

neu2buntu
February 14th, 2009, 05:05 PM
and to post num #3 goto > preferences > sound > sounds ... and untick play alert sound should do it i hope

joelwhrs
February 14th, 2009, 05:16 PM
I have my control set to master, i think when it stoped working i was playing around with the shortcut controls.

joelwhrs
February 14th, 2009, 05:18 PM
When I disable the alert sound it goes to custom sounds and it seems to disable all the other sounds to:((

neu2buntu
February 14th, 2009, 05:22 PM
try goto the shortcuts again and click on the volume up option until it lights up then hit corrosponding key and the same for the volume down ,if you havnt tried this already

joelwhrs
February 14th, 2009, 05:24 PM
I've tried that pretty often already so i went in my brothers acount and his controls worked great.

neu2buntu
February 14th, 2009, 05:26 PM
as for post #8 make sure you untick the 3rd button down "play alert sound" and not the 1st button "play alerts and sound effects" as this disables the login etc sounds

joelwhrs
February 14th, 2009, 05:35 PM
Ok tried that and it works, Thanks alot now all i need to know is how to get my voume control shortcuts to work, but thanks alot.

neu2buntu
February 14th, 2009, 05:43 PM
think i might have it . in my case the speaker icon shows master as my control device but in > preferences sound > devices it is set as pcm... firstly try
[1] change your devive to control in the above mentioned window and try to see if it works

failing that goto your brother account and open up >prerferences > keyboard shortcuts .and copy (write down) the exact values for volume up and volume down then go back to your account and edit them to be the same ... here a screenshot of my values below



also in step [1] probably choose master here...ok

joelwhrs
February 14th, 2009, 05:48 PM
I have checked and i have the same exact configuration as you do but i will copy my brothers and let you know what i find out

neu2buntu
February 14th, 2009, 05:49 PM
did you also try step [1] and set value to master

joelwhrs
February 14th, 2009, 05:51 PM
Ok i checked and we both have the same shortcuts, i was wondering if maybe something got changed in the configuration files that it controls the capture instead of master

joelwhrs
February 14th, 2009, 05:57 PM
yeah the only thing that is there is master, no pcm or anything

neu2buntu
February 14th, 2009, 06:01 PM
you read my mind am just looking at gconf now...... ok goto terminal type

gconf-editor hit return. then pu;ll ddown "apps" and goto > gnome_settings_daemon .. pull it down and click on keybindings and check your volume settings here

neu2buntu
February 14th, 2009, 06:06 PM
one more thing are you controlling the actual right device? open "volume control" again and at the top of this window there is a pull down list of devices. make sure you have chosen something like "alsa mixer" here and not "capture" oh and also check this is what it is set to in > preferences > sound > device

joelwhrs
February 14th, 2009, 06:06 PM
I checked and its what its supposed to be

joelwhrs
February 14th, 2009, 06:09 PM
I checked and it says i got hdaintel(alsamixer)

joelwhrs
February 14th, 2009, 06:11 PM
Here's a screenshot of my sound preferences

neu2buntu
February 14th, 2009, 06:16 PM
i think theres your problem all along goto my post #19 your device is set to capture as in your screenshot (just above your highlighted "master") you need to chang this to "alsa mixer" here and also in volume control (speaker icon on top panel) fingers crossed this will solve it

joelwhrs
February 14th, 2009, 06:19 PM
WOW it works thanks a million:)

neu2buntu
February 14th, 2009, 06:27 PM
no problem... i should have thought of this before all the other posts but you learn everyday...good luck and here a great post by markbuntu that has got my sound setup just the way i want it so it may be usefull to you later
http://ubuntuforums.org/showthread.php?t=843012&highlight=markbuntu+pulseaudio+alsa+jack