PDA

View Full Version : [all variants] No sound with Java and DHTML



E-mol
February 4th, 2009, 10:25 PM
I have found out that i can't hear (or there might not even be played) a sound when i try to play one with Java or DHTML. I try to use in a web page i am writing. Before i have used flash - but, yeah.. I try to avoid that.
I realized the problem when i searched for the scripts to play the sound, found this page: link (http://www.phon.ucl.ac.uk/home/mark/audio/play.htm). I have tested the page in Firefox, Konqueror, Opera, Netscape, IE6 and IE7 in Ubuntu, but none of them worked. Then i tried from windows, mint, liveUbuntu and kubuntu. All those worked - with Firefox (Haven't tried the others there).

For some information:

In my main-distro (Ubuntu), where i can't here anything, do I use VLC as plugin for wav (wich is used in the example), and use alsa.
In windows was it set to quicktime (strange, but worked), it is also tested with wmp and worked.
In mint was it set to wmp-plug in (strange to, but worked),
I don't know what liveUbuntu and Kubuntu was set to, but I'm pretty sure that it was mplayer in kubuntu - and gues its the same with the live one.

In Ubuntu do i use alsa. Don't know with the other distros.

And I have tested Flash and thats just worked.

I have absolutely no idea of whats going on. So I will be very glad for any kind of help :)

Thanks
E-mol

PS. Please don't start discuss the idea of sound on a web page. It's not always annoying. I know what i want ;)

E-mol
February 7th, 2009, 10:43 PM
Bump