View Full Version : [kubuntu] Brother printer problem

February 3rd, 2009, 11:45 PM
I had installed my printer , but after a disaster I re-installed Kubuntu and went through the same procedure again.
This time it didn't work, I tried again and failed again.
I installed brother-lpr-drivers-extra via Adept, I got drivers and CUPS wrapper too, but it failed.

I did a little tinkering in Adept, un-installing the bits and pieces I had installed, so as to start afresh, just in case that was the problem.
Now I cant find Printing via : System ---- Administration ---- Printing.

Can anyone help me to solve this, so I can try again.

February 6th, 2009, 02:24 PM
Appears as if I am on my own then ?

February 6th, 2009, 03:31 PM
I've had loads of problems setting up my DCP 135c under Ubuntu

It did work, then stopped. I tried tons of things to get it to work, but eventually gave up...

I have recently installed Intrepid on my laptop, and I got the printer working straight away.... :roll:

Going to strip the laptop & try Mandriva in a minute - need to get my new Symbian phone synced with evolution...

I think a clean installation (a la Windows) may sort out your problem..

Good luck.

February 6th, 2009, 04:40 PM

The first thing you should do is use the SEARCH feature on this site. Typing Brother printer drivers in the search box will produce results.

Also, this site may help.


Depending on your printer model or MFC model
you will find a wealth of resources.

The Brother Linux page is also a good place to look


Good Luck

February 7th, 2009, 12:14 AM
@m herrin A la Windows ?
Go wash your mouth out.
I have it installed perfectly in windows, with all the bells and whistles.
I wanted to go over entirely to Linux, if I want to print an email I can't, I have some photos I would like to print I can't.
I think I shall try for another distribution before I give up.

@ bigfootnmd I have been to 'the' definitive post on this forum, that's how I installed it first time around, I have been to Brother's site and downloaded the correct everything I needed, plus printed out (in XP) about 12 pages of instructions, and I am still failing.

I think it says more about me and my learning curve, although Brother printers seem to be particularly troublesome to get up and running outside of Windows.

I shall not let it beat me.

Thanks for the replies.