PDA

View Full Version : [ubuntu] Gettting the HP 4180 scanner to work.



Fidelio
January 28th, 2009, 01:05 AM
Just bought an HP 4180 all in one. The installation was mostly great. I plugged it in, it was instantly recognised and printed off a test page.

Just two issues. The print quality seems lower than in windows, with bars of colour in photographs. I can't work out how to set the print quality, and it's like it's printing on 'normal' and I want best for photos, obviously.

I can't get the scanner to work at all. If I click on Xsane, about 30s later I get an error window with: 'Failed to open device....IO error'

I'm slightly peeved. I had a Canon before which I eventually got up and running, but I've seen it written so many times that HP devices work well with linux.
I'm on 8.04, by the way.

Cheers
F

yeats
January 28th, 2009, 01:18 AM
I've had trouble getting xsane to recognize my scanner before too. Have you tried the GIMP? Try File -> Acquire -> [your scanner] - that worked for me, anyway.

Fidelio
January 28th, 2009, 10:51 AM
Thanks. Well that's working beautifully. Strange. I tried that already and got the same error, but I just tried it again to describe what wet wrong and it it worked perfectly. Also, just going straight into Xsane works perfectly too now. So, no idea what happened, but all working sweetly now. Many thanks!