PDA

View Full Version : [ubuntu] Problem with Nvidia GeForce 2 Settings



GSI
January 26th, 2009, 07:01 PM
Here is the problem : When I open Nvidia X server Config and press save to X Server it says: Unable to create new X config backup file '/etc/X11/xorg.conf.backup'.

Tomatz
January 26th, 2009, 07:03 PM
Here is the problem : When I open Nvidia X server Config and press save to X Server it says: Unable to create new X config backup file '/etc/X11/xorg.conf.backup'.

You need to run nvidia settings as root.

Open a terminal and:


gksu nvidia-settings


;)

GSI
January 26th, 2009, 07:24 PM
That worked but now the top bar with the name and the close minimize and maximize options is gone! i really need it back

Tomatz
January 26th, 2009, 07:55 PM
That worked but now the top bar with the name and the close minimize and maximize options is gone! i really need it back

That is probably because you misconfigured the xserver using nivdia settings.

Luckly nvidia settings creates a backup. Do this in a terminal to restore the backup:


cd /etc/X11


sudo cp xorg.conf.backup xorg.conf

Now reboot

;)

GSI
January 26th, 2009, 08:15 PM
Not working :( :(

Tomatz
January 26th, 2009, 08:33 PM
Do the commands again (i have edited the post above^), there was an error in my code :(

sorry.

GSI
January 27th, 2009, 01:43 PM
It seems to be from the effects i turned them off now and everything is fine :)

Tomatz
January 27th, 2009, 01:54 PM
It seems to be from the effects i turned them off now and everything is fine :)

You need to set compiz to either use metacity or emerald (window decoration). If you want to use compiz i can tell you how to do this?

GSI
January 27th, 2009, 02:18 PM
You need to set compiz to either use metacity or emerald (window decoration). If you want to use compiz i can tell you how to do this?

It will be great.But do you have MSN or Skype?

Tomatz
January 27th, 2009, 02:26 PM
It will be great.But do you have MSN or Skype?

Its better to do it on the forums, then others will be able to resolve a similar problem ;)

I'll be back in about an hour.

GSI
January 27th, 2009, 03:14 PM
Oki tell me how :)

Tomatz
January 27th, 2009, 03:38 PM
Oki tell me how :)

Do this:

[EDIT] First, enable desktop effects.

Then


sudo apt-get install emerald compizconfig-settings-manager

Then go to system, preferences, compizconfig settings manager (might be called advanced desktop effects settings).

Now in the compiz settings manager find the "window decoration" plugin. Now enable it by checking the checkbox next to it.

Now it may be set up to use metacity by default so your window decorations may appear but we want nice shiny emerald window decorations so...

Enter the "window decoration" plugin by clicking on its icon.

Now there will be a box with "command" next to it. Put the following command into the box:


emerald --replace

Now you may need to logout to see changes. If not go to system, preferences, emerald theme manager.

Now its all straight forward. There is a link below to a site with emerald themes:

http://compiz-themes.org/index.php?xcontentmode=103&PHPSESSID=cdb367b43b28fb305d00de3c196f0bff

Enjoy

GSI
January 28th, 2009, 11:03 AM
I cant it dosent works :@

Is there any way to remove compiz or reset to default settings?

Tomatz
January 28th, 2009, 11:30 AM
Open a terminal and type:


emerald --replace

Then post the output.

Make sure compiz is running first though ;)

GSI
January 28th, 2009, 11:37 AM
Dosent work...Cmon tell me how to remove the stupid compiz

I dont want to install ubuntu again..

Tomatz
January 28th, 2009, 11:53 AM
Dosent work...Cmon tell me how to remove the stupid compiz

I dont want to install ubuntu again..

Remove it yourself. You have google you know...

Try talking a bit more respectfully.

GSI
January 28th, 2009, 04:03 PM
I'm sorry.I will go wthout effects "_

Tomatz
January 28th, 2009, 05:40 PM
I'm sorry.I will go wthout effects "_

Its ok ;)

I was in a crap, should have left it.

Do you still want to turn off compiz? If so go to System, Preferences, Apperance, Visual effects.

GSI
January 29th, 2009, 07:59 AM
Yes im like that now without effects they are turned off :)

Tomatz
January 29th, 2009, 10:11 AM
Yes im like that now without effects they are turned off :)

Type the following into a terminal and post the output (text from terminal) here:


metacity --replace