View Full Version : [ubuntu] Synaptic package manager dpkg error

January 26th, 2009, 04:55 PM
I think something is wrong.If I try to open Synaptic package manager I get an error message saying

E:dpkg was interrupted, you must manually run 'dpkg --configure -a' to
correct the problem
E:_cache->open()failed,please report.

Also I was trying to download limewire and every time I ran the package manager it said it was busy and could only run one task at a time, but I was not doing anything else. I have rebooted my computer and it satill says the same things

Tim Sharitt
January 26th, 2009, 05:01 PM
Open a terminal and run

sudo dpkg --configure -a

January 26th, 2009, 05:15 PM
Try this then run the update manager:

kill -9 `pgrep update`
If you still get the error, use this command to list running processes:

ps -ax
If you find some update process running in the background use this command
to kill the process:

sudo kill <process number>
If you kill all update processes then try running:

sudo dpkg --configure -a && sudo apt-get -f install
Hope this helps ya.......

January 27th, 2009, 12:50 AM
Thanks guys!