View Full Version : [ubuntu] Installing Java and Frostwire

January 26th, 2009, 02:34 AM
I downloaded Java and Frostwire onto my computer. I am using Ubuntu 8.04. How do I get these programs installed?

January 26th, 2009, 02:37 AM
how did you download java? and also to install frostwire just double click if it is a .deb

January 26th, 2009, 02:41 AM
To download Java I just went to Java.com and downloaded it. I did click on Frostwire but it just kept directing me to package manager telling me to install and that is as far as it would go, it wouldn't open up at all after installing it.

January 26th, 2009, 02:50 AM
Forget Frostwire, install Deluge and GTK Gnutella instead. Both can be installed with Synaptic Package Manager easily with no fuss.

January 26th, 2009, 02:50 AM
go to applications>add/remove and check "sun java 6 runtime" and hit apply. For frostwire try going to just www.frostwire.com and download the one for ubuntu/debian and when it is done there should be a package named "frostwire-4.17.1.i586.deb" double click that. But first get rid of the first things you downloaded.

Crafty Kisses
January 26th, 2009, 02:50 AM
Assuming you saved the Java file to your desktop, and it's named "Java.bin" do the following:

cd ~/Desktop
chmod +x java.bin
sudo mv java.bin /opt
cd /opt
sudo ./java.bin
Once you've done that it will start unzipping the files in the /opt directory, there should be a new directory, and not sure what it would be called, but navigate to it:

cd jre_directory/bin
sudo ln -s /opt/jre_directory/bin/java /usr/local/bin/java
That should get you going with Java. Java is also in the repositories if you don't feel like manually running the script, you can run the following command:

sudo apt-get install sun-java6-plugin ; sudo update-java-alternatives -s java-6-sun

January 26th, 2009, 03:29 AM
Thank you, I ran the second command and i believe i installed it...now it is on a configuring screen and there is nowhere to accept or anything to I just close the window...or how do I configure it?

January 26th, 2009, 03:42 AM
I tried to hit apply under add/remove programs and it said this...E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report.

I tried to run 'dpkg --configure -a' then i was told i wasnt a superuser...any ideas??

Crafty Kisses
January 26th, 2009, 04:52 AM
Try running the following:

sudo dpkg --configure -a
Then after that try reinstalling the Java package:

sudo apt-get install sun-java6-plugin ; sudo update-java-alternatives -s java-6-sun

January 26th, 2009, 05:18 PM
whenever it says that you need super user privilages just run the same command with sudo in front of it. :)

January 26th, 2009, 07:00 PM
you have another thread on the same topic:
please keep track of your threads, rather than starting new threads
cheers :)