View Full Version : [ubuntu] Resolution problem

January 23rd, 2009, 08:33 PM
I installed Ubuntu on my second computer to try to get used to how it works before possibly installing it on my main computer. I have a 26 inch LCD HDTV monitor so my first order of business was to get the correct drivers for my video card - NVIDIA FX 5200 - installed so I could set the resolution to it's proper 1280x768. I clicked on the "Add remove Programs" utility and it showed a NVIDIA driver and control panel that could be downloaded and installed and so I did. Then restarted the computer. I then activated the new driver and restarted again.Once it was restarted the resolution had changed from 800x600 to 640x480.I opened the new NVIDIA control panel and it wouldn't let me change the resolution.

I have also downloaded and installed all UBUNTU updates.

I tried changing the screen resolution with grandr without success

I tried...

sudo /etc/init.d/gdm stop
sudo nvidia-xconfig
sudo /etc/init.d/gdm start

and that didn't do anything. A person on another board asked me to do this

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf_backup
gksudo gedit /etc/X11/xorg.conf

and paste the results for him to see so I'll do the same here

# xorg.conf (X.Org X Window System server configuration file)
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Monitor"
Identifier "Configured Monitor"

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24

Section "Module"
Load "glx"

Section "Device"
Identifier "Configured Video Device"
Option "NoLogo" "True"
Driver "nvidia"

Then they asked me to run this

xrandr -q

and paste back the results. So here it is.

Screen 0: minimum 320 x 240, current 640 x 480, maximum 640 x 480
default connected 640x480+0+0 0mm x 0mm
640x480 50.0*
320x240 51.0

So, they thought I needed a new xorg.conf file and so they made me one and lead me though the process of replacing my old one with the new one. After that I restarted but it didn't seem to have any effect on it at all. I'm still not able to change my resolution. So they sent me over here for further help. I have read a few threads on there concerning similar problems but I haven't found anything that directly applies to my problem. I'm VERY new to linux so if you give me any instructions please try to make it as simple as possible.