View Full Version : [ubuntu] Running Thunderbird in different locale

January 23rd, 2009, 07:16 PM
Not sure if this is the right section, but oh well.

Since i'm using Windows XP on same machine, i want to keep Thunderbird email synchronized between XP and Ubuntu 8.10. And since XP is deficient, to prevent Ubuntu's Thunderbird from screwing up my CP1251 folder names with it's UTF8 locale i have to run Thunderbird with LANG=ru_RU.CP1251. This works fine from the terminal, but when i try to set it as a default application (System -> Preferences -> Preferred Applications -> Mail Reader -> Custom and "LANG=ru_RU.CP1251 thunderbird %s" command) - it fails with a prompt that says "Couldn't execute blablabla, verify that this is a valid command". This IS a valid command and it works fine in terminal. What's wrong?

January 24th, 2009, 01:14 AM
c'mon, is it so hard to change an application locale in GNOME without using the terminal?