View Full Version : [ubuntu] Ubuntu 8.10 64 bit installed but could no boot, grub was no installed.

January 23rd, 2009, 05:15 PM
I tried several times to install Ubuntu_8.10_desktop_amd64 on My laptop ( dual intel(R) Core(TM) Duo 2.2Ghz cpus). I have another two existing system : 1) ubuntu 8.04.1 32 bit 2) windows xp. and grub was installed.

I download the .iso file from Ubuntu official website, tried the live CD, made integrity check, it all worked well. I then installed the system to a new partition, the installation gave no error. But when I restart the computer, I could not boot Ubuntu 8.10, either no grub could be found or the old grub was shown (after I manually install grub) . There was no entry added by the installer, nor /grub/ folder under /boot/ folder on the partition of the new installation.

I'm a bit desperate now, but still with the hope of 64bit power. Any hints are welcome, Thanks a lot in advance!

January 23rd, 2009, 05:42 PM
Install Grub to it's own partition and later edit menu.lst of original Grub to add the new entry.
Or try to reinstall Grub:

January 24th, 2009, 06:12 AM
Thanks a lot for Pumalite's reply.

Following this advice to I tried to install grub in the partition of Ubuntu 8.10 64 bit, but still failed. I got: "Could not find device for /boot: Not found or not a block device."

After some search, I found another post, the problem described is quite similar to mine: