View Full Version : [ubuntu] Probs with compilling r8168 driver

January 20th, 2009, 04:29 PM
Hello guys. First sorry for my bad english.
Second i have some probs when i trying compile driver from Network card realtek 8168.

When i try it i all time got message like this

woo@Gameaction1:~/work/r8168-8.009.00$ make clean
make -C src/ clean
make[1]: Entering directory `/home/woo/work/r8168-8.009.00/src'
rm -rf *.o *.ko *~ core* .dep* .*.d .*.cmd *.mod.c *.a *.s .*.flags .tmp_versions Module.symvers Modules.symvers *.order
make[1]: Leaving directory `/home/woo/work/r8168-8.009.00/src'
woo@Gameaction1:~/work/r8168-8.009.00$ make modules
make -C src/ modules
make[1]: Entering directory `/home/woo/work/r8168-8.009.00/src'
make -C /lib/modules/2.6.27-9-server/build SUBDIRS=/home/woo/work/r8168-8.009.00/src modules
make[2]: Entering directory `/lib/modules/2.6.27-9-server/build'
make[2]: *** No rule to make target `modules'. Stop.
make[2]: Leaving directory `/lib/modules/2.6.27-9-server/build'
make[1]: *** [modules] Error 2
make[1]: Leaving directory `/home/woo/work/r8168-8.009.00/src'
make: *** [modules] Error 2

i already download all what nedded for compilling. Source Headers esentialle etc .... Can some one halp me a bit with this trouble ?
Perf: Quad core MB:Gigabyte P45-DS3L Ubuntu server 8.10 x64

April 6th, 2009, 10:51 AM
I had the same issue. This fixed it for me:

I just downloaded the tar and ran:
tar xjf r8168_scripts.tar.bz2 && cd r8168_scripts && sudo ./switchmods;
like the page says. It fixed everything.

The page also shows you how to build the driver from the source (which also worked for me).

Here is the source: