PDA

View Full Version : [ubuntu] Dell D830,BCM4312, 8.1.0 connecting with WEP



linnewb
January 19th, 2009, 08:42 PM
Hi,
I am having some issues with WEP connections using network-manager and the b43 driver. I have been doing a lot of reading on this forum and I am not sure if I should be trying to use the ndiswrapper setup, or stay with the b43 driver.

I can connect to my home wireless Dlink DIR-655, the router is set to wpa or wpa2, tkip or aes. But I cannot connect to my works WEP network. When I enter the wep wireless settings, network-manager tries to connect but fails. I have tried the STA driver that is in Admin --> Hardware Drivers, but can't connect to any network with that driver.

Any help is appreciated.


modinfo b43
filename: /lib/modules/2.6.27-9-generic/kernel/drivers/net/wireless/b43/b43.ko
firmware: FW13
license: GPL
author: Michael Buesch
author: Stefano Brivio
author: Martin Langer
description: Broadcom B43 wireless driver
srcversion: 9B6D0D14CB834660F8EAC23
alias: ssb:v4243id0812rev0D*
alias: ssb:v4243id0812rev0B*
alias: ssb:v4243id0812rev0A*
alias: ssb:v4243id0812rev09*
alias: ssb:v4243id0812rev07*
alias: ssb:v4243id0812rev06*
alias: ssb:v4243id0812rev05*
depends: mac80211,ssb,input-polldev,led-class,rfkill
vermagic: 2.6.27-9-generic SMP mod_unload modversions 586
parm: bad_frames_preempt:enable(1) / disable(0) Bad Frames Preemption (int)
parm: fwpostfix:Postfix for the .fw files to load. (string)
parm: hwpctl:Enable hardware-side power control (default off) (int)
parm: nohwcrypt:Disable hardware encryption. (int)
parm: qos:Enable QOS support (default on) (int)
parm: btcoex:Enable Bluetooth coexistance (default on) (int)


iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11bg ESSID:""
Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
Tx-Power=27 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0


lshw -C network
WARNING: you should run this program as super-user.
*-network
description: Network controller
product: BCM4312 802.11a/b/g
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:0c:00.0
version: 01
width: 32 bits
clock: 33MHz
capabilities: bus_master cap_list
configuration: driver=b43-pci-bridge latency=0 module=ssb
*-network
description: Ethernet interface
product: NetXtreme BCM5755M Gigabit Ethernet PCI Express
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:09:00.0
logical name: eth0
version: 02
serial: 00:21:70:71:c2:8a
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list ethernet physical
configuration: broadcast=yes driver=tg3 driverversion=3.94 firmware=5755m-v3.29 ip=10.18.20.94 latency=0 module=tg3 multicast=yes
*-network:0
description: Wireless interface
physical id: 1
logical name: wlan0
serial: 00:22:68:99:0b:5f
capabilities: ethernet physical wireless
configuration: broadcast=yes multicast=yes wireless=IEEE 802.11bg
*-network:1 DISABLED
description: Ethernet interface
physical id: 2
logical name: pan0
serial: 16:51:23:e6:91:3b
capabilities: ethernet physical
configuration: broadcast=yes driver=bridge driverversion=2.3 firmware=N/A multicast=yes

linnewb
January 20th, 2009, 12:27 AM
When I use the STA driver to connect to my home WPA/WPA2 network I get prompted for the password to join the network over and over again.

linnewb
January 20th, 2009, 04:49 PM
Well, I did get the b43 driver to connect to my works WEP network one time with network manager. What seems to be happening is that NM doesnt always see open wireless networks. When click on the NM icon, sometimes I see open network signal strengths and sometimes I dont. I have to use sudo /etc/init.d/NetworkManager stop and start to see them again.

Also, iwlist wlan0 scan doenst show networks even when NM does see them.

Help please!

linnewb
January 20th, 2009, 10:02 PM
Still using the B43 driver, removed network-manager and installed wicd.

Everything is working great now.

Thanks for all the help!

gnuskool
November 16th, 2009, 11:40 PM
Post #3 worked for me!

Just copy paste this

sudo apt-get install b43-fwcutter

The rest is done for you...then reboot. Works perfect after that.:popcorn: