View Full Version : [ubuntu] Run gnome-ppp as Normal User

January 19th, 2009, 08:21 PM
In Ubuntu 8.04 Hardy, I had my Samsung SPH-M610 cell phone with Sprint service tethered and working as a modem using kppp. Sprint provides detailed although somewhat dated instructions for getting this working in Ubuntu with kppp.

After installing Ubuntu 8.10 Intrepid I decided to try and get the M610 tethered using gnome-ppp and skip installing all of the KDE dependencies. The good news is that gnome-ppp works. The bad news is that it must be run as Super User, I have to open terminal and run sudo gnome-ppp

If I try to run gnome-ppp as a normal user I get the following error message in gnome-ppp log:

Unable to run /usr/sbin/pppd.
Check permissions, or specify a "PPPD Path" option in wvdial.conf.

I have tried creating the user group "dip" with GUID 30 and adding my user account as suggested elsewhere on the internet. This did not work. I have also tried chowning pppd to my user rather than root. I can get connected after doing this but only for a split second and then gnome-ppp disconnects.

Is there any way to run gnome-ppp as a normal user in Ubuntu Intrepid?

January 19th, 2009, 08:50 PM
even though they are talking about different commands, it worked for me

I also chmod /usr/sbin/gnome-ppp to 555

January 19th, 2009, 09:37 PM

file does not exist.

i tried running this command:

sudo chmod u+s /usr/sbin/pppd

still getting the same error after relogin.

January 19th, 2009, 09:40 PM
I first chmod /usr/bin/gnome-ppp to 555 did not work but the steps in section #2 in that linked website worked for me

I'm using gnome-ppp for my AirCard 860

January 21st, 2009, 01:38 AM
I found this fix on another thread:


I only needed the first two lines to get gnome-ppp working as a normal user:

sudo chown root:dip /usr/sbin/pppd
sudo chmod 4754 /usr/sbin/pppd

Hopefully this is more user-friendly in Jaunty :)

June 26th, 2009, 09:20 PM
ieee488's (Posting #2) Using visudo to edit the /etc/sudoers file worked for me.
Now the icon I have on the desktop of my Dad's laptop executes sudo gnome-ppp as root but does NOT ask for the root password.

There's a good explanation (not to wordy and easy to understand (I hope))
of the sudoers file at https://help.ubuntu.com/community/Sudoers