View Full Version : [ubuntu] Getting mic to work on Sony Vaio VGN-CS215J

January 18th, 2009, 10:39 AM
I just purchased a Sony Vaio VGN-CS215J for my wife. Almost everything works out of the box and I am overall very happy with it. However, I can't get the built-in microphone to work in Skype.
I have followed this guide:
but nothing seems to work. Don't really know if I do it right but I tried to add the following lines in /etc/modprobe.d/alsa-base:

options snd-hda-intel model=vaio
options snd-hda-intel model=sony-assamd
options snd-hda-intel model=base

I have no none of them in this file, but as a result, the osund is now very low. How come, since it is back to when I started?

cat /proc/asound/card0/codec#* | grep Codec gives me:

Codec: Realtek ALC262
Codec: Conexant ID 2c06

I have even replaced Pulseaudio with Esound.

I am now running out of ideas and would like to ask for help.
So if anyone has an idea, please let me know.


March 18th, 2009, 08:42 PM
me too! same hardware, same problem

April 28th, 2009, 04:38 AM
Since this laptop runs on an Intel graphic card, upgrading to Jaunty is completely out of the question, so I can't test if this problem still exists. Have to wait for Karmic Koala.

July 7th, 2009, 11:05 PM
Another update:

I just purchased a Vaio for myself (VGN-NW150J) and I am having the same problem.
The internal mic does not work, but the extrenal one does. The only work around I use right now is using an external mic plugged in to the laptop. The one I use currently is a Sony ECM-DS30P that can be found HERE (http://www.sonystyle.com/webapp/wcs/stores/servlet/ProductDisplay?catalogId=10551&storeId=10151&langId=-1&productId=11035572)

July 14th, 2009, 09:34 PM
I have a Lenovo Y410 but it uses the ALC262 , same audio I believe because my mic doesn't work either. The sound drivers are a major pain for this regardless of OS

July 14th, 2009, 10:54 PM
Ask on OSS4 forum, if they have such driver for OSS

July 17th, 2009, 08:08 PM
I have a Lenovo Y410 but it uses the ALC262 , same audio I believe because my mic doesn't work either.
Does the external mic work for you, as in, can you plug in a mic and use it like I do? I don't have a solution, I'm just curious if it's the same dealio for you.

July 26th, 2009, 12:55 PM
I have a Sony Vaio VGN-CS14G laptop and have this same problem, the internal mic is not working. I cant use skype because of this :(. Did anyone find a fix yet?
Please help...

July 28th, 2009, 12:55 AM
Like I mentioned earlier, the only way you can use Skype (without mad Linux hacking) is by buying an external mic. The one I use, which is a pleasure to use and does not take up much room either, is THIS ONE (http://www.sonystyle.com/webapp/wcs/stores/servlet/ProductDisplay?catalogId=10551&storeId=10151&langId=-1&productId=11035572)

July 29th, 2009, 01:52 PM
When I got my VGN-NS325J I was actually looking at the hardware figuring to get something that was actually within 100% lin compatibility.. so after all this turns out that everything worked out of the box EXCEPT the internal Mic. While I know it sounds picky.. I guess I just cant get 100 % without BG >:(

Incidentally I have the same reponse for Codec as our first poster.. I did come across one post somewhere that mentioned typically parts were provided by BIOS settings however my particular model has no such settings in BIOS. So it might just be a matter of getting it what it needs to actually use the thing.