View Full Version : [ubuntu] 8.10 installed on laptop; USB stick not mounting

January 18th, 2009, 02:02 AM
Would someone please indicate how to get Ubuntu 8.10 Desktop version to automatically mount USB memory sticks? I have attempted to detect the device using the terminal but no memory stick is on the lsusb results. :confused:

January 18th, 2009, 09:27 AM
if you are running windows, with dual boot, then safely remove the usb stick from windows. sometimes if in windowa you don't do this, ubuntu is unable to mount the stick.

and install a graphical tool for mounting. go to synaptic and search ntfs-3g

hope it helps.

January 18th, 2009, 09:40 AM
Hi mdedwards

I have found that some batches of CORSAIR USB sticks will work under windows but not under Ubuntu. There is some information on this on the Corsair web site, but at least last time I looked no real resolution. I gather that i9ts not Ubuntu per se but rather versions of the Linux kernel but I can't verify that as I only run Ubuntu.

I would recommend trying another brand of USB stick.

I assume you have checked the obvious being:

You haven't changed logged in user while stick was already mounted

You have tried restarting Ubuntu

I also note that on one occasion I could not get a Ubuntu box to mount a USB stick for a routine daily data backup so I wrote the data to a CD instead. And for some reason that I can't fathom once I had burnt the CD the USB stick magically auto mounted (I had left it attached).

Hoping that maybe thats of some help to you.

January 18th, 2009, 04:39 PM
Thanks for your time and insight. I do have a Corsair 64GB memory stick, with which I have been attempting to use with this new install of Ubuntu. Yes, Ubuntu is the only OS installed on this laptop.

I tried to write some files to a CDRW and this was painless, and as you suggested, I kept the USB memory stick plugged in during the write, and I rebooted as well. Still have the same "USB Drive" option in the Places drop down, but when hovering the mouse over this it only displays "Rescan Drive" and when clicked it does absolutely nothing even after waiting for some time.

I did check to see whether it could see my 1GB SD card from my camera and this was no problem. I've tried some of the workarounds I've been finding on some forums but none seem to work, for example modifying fstab and manual mounts etc, I'm determined to figure this out, anymore suggestions?

Thanks in advance for your time and help!!!!