PDA

View Full Version : [ubuntu] gnome sounds not playing



eyecreate
January 17th, 2009, 11:47 PM
I just noticed this problem because I was trying to change the sounds in gnome to custom sounds. It seems that only the login/logout sounds actually play, whereas, no matter what sounds are already there or I replace with custom sounds of any type, they will not play in gnome. ex. I tried to change the empty the trash sound and no matter how many times I made a empty file, deleted it, and emptied the trash, there would be no sound. What could cause this?

thomasaaron
January 18th, 2009, 01:24 AM
Are you adding your own custom sound files? If so, make sure they are the same format as the originals... I believe they are .ogg

Also, you probably have to reboot after making changes.

Let me know if I'm misunderstanding.

eyecreate
January 18th, 2009, 04:14 AM
I will try rebooting on custom sounds, but I don't know if that is it. It doesn't seem to just be custom sounds, but also default sounds that came installed. I never have heard the ubuntu warning sound on my computer and didn't know there was one till I looked in the sound menu. It seems to just not be playing them.

thomasaaron
January 18th, 2009, 05:13 AM
I get a single drum beat for the Warning sound.
I don't get a Battery warning sound though.

I'm testing in System > Prefs > Sound > Sounds.

Maybe you just need to assign them. To find all (or most) of your system's sounds run...

locate *.wav

Most of them are in /usr/share/sounds/

makro
January 18th, 2009, 09:51 AM
I can confirm sounds for buttons click and alert dialogs don't work in intrepid. Any helps? (I've enabled them in System/Sounds)

thomasaaron
January 18th, 2009, 04:26 PM
Hi, Macro.

Look at the thread just above yours. Try to assign custom sounds to whatever you want.

I'll tinker with it when I get back in the office tomorrow.

eyecreate
January 18th, 2009, 07:07 PM
it's not that it can't find the sounds, as when I click the play preview button, I hear the sound that should play, but it never plays for real.

thomasaaron
January 18th, 2009, 08:23 PM
Bingo...

https://bugs.launchpad.net/ubuntu/+source/libcanberra/+bug/273507

eyecreate
January 19th, 2009, 07:26 PM
i think that fixed it. thanks!