PDA

View Full Version : [ubuntu] .exe app running on my computer but not on my sister's



atropa
January 17th, 2009, 08:34 PM
I've tried to install Cambridge Advanced Learner's Dictionary 3rd Ed on two hp laptops. While it installs and runs flawlessly on mine (using wine), it doesn't install on the other.

Both hp notebooks (8530w and 6530b) are set up with ubuntu 8.10 with the latest updates. The list of all installed packages only differs by a few linux apps like kile and some texlive stuff
wine version: 1.0.1

I've also tried to install on both of them the same .exe apps in case some install introduced some additional dll's

The not working install briefly flashes up the window to click the "next" button, but then it vanishes again and only the black-blue background remains.

I run the install using WINEDEBUG with options warn=+all in the first file
and +relay, +seh, +tid in the second file.

You can access these error logs on:

http://n.ethz.ch/~sebkelle/download/

the warn=+all file is much shorter than the other one

also on the notebook on which it's working, the winedebug produces quite a lengthy log

Has anyone got an idea why these ubuntu installs should behave differently?

ac7ss
January 18th, 2009, 03:00 AM
It looks like you don't have a directory set up as C:. run the winecfg and make sure that there is a mapping for C:

atropa
January 18th, 2009, 11:20 AM
Wine sets up the c: directory correctly during its installation.
It's still there and has not been altered since (i.e. there is a mapping to c: )

ac7ss
January 18th, 2009, 09:56 PM
That is the only trouble I have had with wine, mapping. Your logs show that it is not finding the proper files by path.

atropa
January 19th, 2009, 09:44 PM
when I browse the mappings everything looks ok. I've deinstalled, then reinstalled wine, but it didn't help.

If wine really isn't finding the stuff it needs, how can I prevent this from happening?

Btw: This Cambridge Dictionary also isn't working on my father's laptop and on my friend's, all set up with Intrepid. This is just weird.

atropa
February 5th, 2009, 01:01 AM
The problem was the install window beeing hidden beneath the blue installer background. I could retrieve it with Alt + tab

Some unknown window settings must have caused the window to show up on my computer and to hide an all others.

Despite the programm now running well, wine reported bad errors such as missing system files and so on.
So I was quite surprised about such a minor cause.