View Full Version : [ubuntu] Newbie: Add/Remove not working

January 17th, 2009, 07:14 PM
I've just installed Ubuntu 8.10 and within hours I've already come up against a brick wall. I installed some games via Add/Remove: gunroar and nexuiz. After trying them out I tried to remove them again using Add/Remove however I get this error message:
Changes applied

Not all changes and updates succeeded. For further details of the failure, please expand the 'terminal' panel below.

dpkg: unable to stat triggers deferred file `/var/lib/dpkg/triggers/Unicorp`: S tale NFS file handle

I have tried using Synaptic to remove them or anything and I still get denied.

Any help resolving this would be gratefully received


January 17th, 2009, 07:27 PM
Close any apt and dpkg open process and recheck it by using

sudo ps -A | grep dpkg
sudo ps -A | grep atp
If any result is shown
sudo kill -9 pid# of process
Delete the package from /var/cache/apt/archives than delete the unicorp

sudo rm /var/lib/dpkg/triggers/Unicorp
and rename the new unicorp

sudo mv /var/lib/dpkg/triggers/Unicorp.new /var/lib/dpkg/triggers/Unicorp

January 18th, 2009, 08:02 AM
Thanks for the reply. Unfortunately when I try the second step I get this response:

rm: cannot remove `/var/lib/dpkg/triggers/Unicorp': No such file or directory

Not sure what to do or why this is occuring, anyway thanks again for the assistance.


January 18th, 2009, 11:09 AM
If that doesn't solve your problem try this:

$ cd /var/lib/dpkg/
$ sudo mv status status.broken
$ sudo cp status-old status
$ sudo apt-get update

January 18th, 2009, 01:26 PM
Thanks, I tried it and now get this: bash: $: command not found

Anyway I appreciate the help.