PDA

View Full Version : [ubuntu] Keyring Initialization



cmnorton
January 16th, 2009, 01:03 AM
At the end of configuring Network Manager in 8.10, I am prompted to enter a password for a keyring. I use my own password, thinking the ring is asking for the sudo password, but that's not it. I tried a blank password, and that did not work.

Is there a way to initialize and use the keyring or not to use it at all? Or, is there a default password if keyring has never been used before?

This is a brand new Ubuntu system.

Edit:
---------------------------------------------------
I Googled this problem. It can be fixed if a .gnome2/keyrings/default.keyring exists, but I did not have one. I have not yet solved the problem, but am continuing to look.

Edit 2:
----------------------------------------------------
By creating a default.keyring in

Applications --> Accessories --> Passwords and Encryption Keys --> Edit --> Preferences

and adding a default keyring, fixed this problem. After rebooting, I was prompted for the password, which I had set (above), and then was asked if Network Manager could have access to it. I chose always.

This is still not solved; I would like the default keyring not to prompt me for a password.

jdb
January 16th, 2009, 04:40 AM
At the end of configuring Network Manager in 8.10, I am prompted to enter a password for a keyring. I use my own password, thinking the ring is asking for the sudo password, but that's not it. I tried a blank password, and that did not work.

Is there a way to initialize and use the keyring or not to use it at all? Or, is there a default password if keyring has never been used before?

This is a brand new Ubuntu system.

Edit:
---------------------------------------------------
I Googled this problem. It can be fixed if a .gnome2/keyrings/default.keyring exists, but I did not have one. I have not yet solved the problem, but am continuing to look.

Edit 2:
----------------------------------------------------
By creating a default.keyring in

Applications --> Accessories --> Passwords and Encryption Keys --> Edit --> Preferences

and adding a default keyring, fixed this problem. After rebooting, I was prompted for the password, which I had set (above), and then was asked if Network Manager could have access to it. I chose always.

This is still not solved; I would like the default keyring not to prompt me for a password.

If you can remove the keyring password & get it to the point where its asks you for a new password the first time just hit the return key.
From then on it will store passwords un-encrypted & not ask you for a keyring password anymore.

jdb

thomasaaron
January 16th, 2009, 05:26 PM
Jeesh. I don't get this keyring junk. I wish they'd just ditch it. I've never heard anybody say: "Wow! I sure love Ubuntu's keyring feature!"

cmnorton
January 17th, 2009, 02:24 PM
If you can remove the keyring password & get it to the point where its asks you for a new password the first time just hit the return key.
From then on it will store passwords un-encrypted & not ask you for keyring password anymore.

jdb

Of course you will feel guilty -- even if for a small amount of time -- when it warns you everything will be unencrypted. I don't even mind it's there, as much as it would not work the first time.

Also, you should be able to override it for network stuff.

jdb
January 17th, 2009, 04:00 PM
Of course you will feel guilty -- even if for a small amount of time -- when it warns you everything will be unencrypted. I don't even mind it's there, as much as it would not work the first time.

Also, you should be able to override it for network stuff.

Not many applications really use the keyring, wifi & email passwords are the heavy hitters.

The nice thing about it being unencrypted is you can look & see whats there. The file is
~/.gnome2/keyrings/default.keyring
.

As long as no one has access to your login it is safe from prying eyes.
The permissions on the file are read/write for user only.
I suppose some sort of malware with your (or roots) ownership could access it, but that's the type of thing you find on windoze, not Linux.

Never let a machine make you feel guilty :P

jdb

Bertybulldog
May 26th, 2009, 12:45 PM
This is really getting on my nerves.

I am having to reinput the x million character long wifi key everytime I start the computer. Surely to god they can fix this crap?

If I don't get it sorted this afternoon I going back to windows.

Why is it that every new iteration of Ubuntu has a (different) deal breaker in it? :mad:

miniyak
May 26th, 2009, 05:19 PM
i think this was addressed in another post but if your having the same issue i was having all you have to do is right click on the network icon, choose "edit connections" go to the wireless tab, select your network, click edit, then finally mark the checkbox in the lower left hand corner that says "allow for all users". enter your password in and you should be good.

It is unfortunate that ubuntu still has a lot of dumb user space issues when it is supposed to the user friendly distro. regardless i think windows is only really usefull for gamers and luddites. i did spend alot less time fixing stuff in windows, but this is because most of the problems were unfixable. lol (note: keyword being "useful" not to offend any windows users)

earrame
May 26th, 2009, 05:41 PM
Hey! I am a Windows user. At work. The honeymoon starts anew everyday when I get home to my Pangolin.:D


Jeesh. I don't get this keyring junk. I wish they'd just ditch it. I've never heard anybody say: "Wow! I sure love Ubuntu's keyring feature!"

I don't know what a keyring is or what it does. I ignore it and it hasn't bothered me.

Having to input the wifi key happened to me a few times. After the first time I thought this would get old in a hurry. But it didn't persist and it hasn't happened in many months so I never persued corrective action. I've had it on other wifi networks this year as well and it always remembers how to get back on the home wifi.

Sea Lint
July 8th, 2009, 06:07 PM
Edit 2:
----------------------------------------------------
By creating a default.keyring in

Applications --> Accessories --> Passwords and Encryption Keys --> Edit --> Preferences

and adding a default keyring, fixed this problem. After rebooting, I was prompted for the password, which I had set (above), and then was asked if Network Manager could have access to it. I chose always.


For those 9.04, the path is: Applications --> Accessories --> Passwords and Encryption Keys --> File --> New --> Password Keyring

Type "default" for the keyring name. Good Luck!

Derath
July 8th, 2009, 06:42 PM
Here's a how-to that was posted in order to get around this:
http://ubuntuforums.org/showpost.php?p=2776815&postcount=1

rebelxt
July 21st, 2009, 10:42 PM
For those 9.04, the path is: Applications --> Accessories --> Passwords and Encryption Keys --> File --> New --> Password Keyring

Type "default" for the keyring name. Good Luck!

If the "default" name already exists, right-click>delete it first.

epicmaster
February 28th, 2010, 01:44 AM
try using 'admin' as the password

thomasaaron
March 1st, 2010, 05:17 PM
If you go to your home folder and then click Ctrl-H, it will show you all of your hidden files.

Find and double-click the folder entitled .gnome2

Then click on the folder entitled .keyrings

Then delete everything in that folder.

It will give you a fresh start on your keyrings.

nodnolse1
August 18th, 2010, 01:36 AM
If you can remove the keyring password & get it to the point where its asks you for a new password the first time just hit the return key.
From then on it will store passwords un-encrypted & not ask you for a keyring password anymore.

jdb

Done, next time i need to log me at ssh server ill see if it work. at the moment thanks