View Full Version : [ubuntu] Can't connect but can seen networks

January 10th, 2009, 06:58 PM
So, I'm kinda a computer n00b. I just recently installed Linux. I wanted to dual-boot it with Vista, but being the n00b I am, I ended up wiping my disk clean. Anyway, now that I have linux running, I am not able to get online via my wireless network. I know it's recognizing my card (it's internal), because I am getting a list of the networks close to me. The problem is is that I can't connect to my network even with the correct encryption key. I'm simply stumped. Maybe it's an easy fix. Anyone had this problem before?

January 10th, 2009, 07:44 PM
If your problem is that it just hangs on "Attempting to join the wireless network 'name of your network'" for a while, try changing the Security Type. If that's set wrong, it can cause it to get stuck trying to connect.

January 10th, 2009, 08:22 PM
Nope, got the right security type...WPA. It tries to connect for a bit then the "Wireless Network Authentication Required" window just pops back up like I didn't even type in a password. I get no errors. And the weird thing is is the password changes itself into a very long password when the window pops back up! I just don't get it. Is there a line of code I have to input somewhere?

January 10th, 2009, 10:14 PM
What distro of linux are you using?
if it is ubuntu 8.10, don't be suprised.
What I do is buy another wireless dongle, and ubuntu often will recognize it. Be sure not to destroy the packaging, because you may need to return it. Before you buy it ask the clerk if you can return it if it does not work with your distro.
I usually just settle for wired, it's faster anyway.
I repair computers to pay for my geek supplies.
In 8.10, if you can see them it's not a driver issue.
It's a bug.
I tried everything in every post on just about every website, and in 8.04 it works just fine.
long live linux!

January 10th, 2009, 10:23 PM
Hey, I'm actually having the same problem on my laptop (I posted about it elsewhere). I recently had Ubuntu 7.10 installed and wireless worked there, then I switched to 8.10 and it stopped. So, I'm thinking I might just try switching to 8.04. Do you think there's a chance wireless would work under that version and do you think I'm sacrificing much by downgrading?