View Full Version : [ubuntu] Strange terminal refresh flicker - with video!

January 6th, 2009, 04:08 PM
The easiest way to describe this problem is to watch this video:

Basically if the gnome-terminal is scrolling and I switch to Eclipse (I think it actually happens whenever the terminal is out of focus) it will start to flicker -- the background disappears and text becomes all garbled. If I return focus to the terminal window and refresh it, it clears up again. It also has something to do w/ the size of the terminal window -- if the window is smaller than, say 1/4 of the screen it doesn't seem to happen.


Ubuntu Intrepid (I think it happened in Hardy too), kernel 2.6.27-9
AMD x64 workstation w/ Nvidia Quadro FX 1500 GPU
NV binary drivers v177.80
Dual display

I don't think this is a Compiz problem; it occurs even if Compiz is disabled.

I have searched everywhere for this behavior with no results... Any ideas?? If anyone else can even confirm that they've seen this behaivor, I'd be thrilled. Thanks.

January 7th, 2009, 06:00 PM
Follow up -- here are two screenshots of what it looks like when it 'flickers' -



Bucky Ball
January 7th, 2009, 06:05 PM
Tried a different driver? nvidia-glx-new?

January 9th, 2009, 03:14 PM
Tried a different driver? nvidia-glx-new?

Hmm no I don't believe I've tried that (although it sounds familiar)... What is the difference between nvidia-glx-new and nvidia-glx-177?

If I install "new" and use the "hardware drivers" console to switch between them, do I have to worry about backing up xorg.conf or any other files?

Thanks in advance...

January 21st, 2009, 09:27 PM
Tried a different driver? nvidia-glx-new?

I just installed nvidia-glx-180 (maybe this used to be the "-new" driver?)

Anyway, I haven't really thought about it all day but I think that might have fixed it...

Bucky Ball
January 22nd, 2009, 04:04 AM
That is good news. You will find 'nvidia-glx-new' in Synaptics. The driver to use depends on the age of your card. 177 I think is the oldest. You are probably using 'nvidia-glx' with the 180. Not really sure but check with a search in Synaptics for 'nvidia-glx' maybe.

Basically though, if it ain't broke, don't fix it! Sounds like you might have fixed it.