View Full Version : [kubuntu] wireless device is disabled

January 5th, 2009, 10:00 PM
I have a USB wifi device attached by my kubuntu 8.10 setup. When I run iwconfig the device is recognized. When I run iwlist ra0 scan it successfully returns the SSIDs from my local area, including my wifi router.

The problem is knetworkmanager tool doesn't allow me to create a new connection using this device. When I right click on it it says "ra0 wireless is disabled".

I tried to create a new connection and choose that device, but the SSIDs don't show up in the list.

How can I configure my wireless through the console, or how can I get knetworkmanager to let me create a connection with this device?


January 6th, 2009, 03:18 AM
I'm reading the wifi docs found here:

When I try to do this:
sudo iwconfig <ath0> essid <essid> ap <xx:xx:xx:xx:xx:> key <XXX> mode <> commit

using my settings, I get an error message like:
SET failed on device ra0 : operation not permitted

I tried it as sudo, but that doesn't seem to affect it.