View Full Version : [ubuntu] 7.10 => 8.04 update issue

January 5th, 2009, 03:40 AM
Hi all,

This question is with regard to my mother-in-law's computer. We installed 7.10 a while back and she's been happy with it, until she needed a CD burning app. Since 7.10 didn't have Brasero, we decided to update her to 8.04 (and then possibly to 8.10).

Since we only had limited time with her over Christmas, we started the update and left town. The update failed at some point along the way, we're not really sure where.

When she boots up, she gets a blank desktop screen with no panels or icons, but an active cursor. It does allow her to log in. Booting into failsafe Gnome is successful, though she doesn't have networking and (for some reason) we can't offload her data to a jump drive to prepare for a clean install of 8.10.

So here's the question: is there some repair tool or something we can run under failsafe Gnome to resolve the issue? Since I'm not sitting in front of the machine in question (and frankly I'm not the best at repairing broken Linux systems), the more automated this is, the better.

Thanks in advance!

January 5th, 2009, 03:59 AM
Unfortunately I don't know of any repair utility beyond booting to Recovery Mode from an Ubuntu CD, but that's hardly a non-geek-friendly or automated solution.

If I were you, I'd probably just try to backup her data and then reinstall Ubuntu. I know you say that you were unsuccessful in trying to copy her data to a flash drive, but how hard did you try? Failsafe Gnome probably doesn't auto-mount flash drives when you plug them in; I would imagine that this was why you couldn't copy the data. However, you should still be able to mount the drive manually from the command-line using commands like this:

sudo mkdir /media/FLASH-DRIVE
sudo mount /dev/sdb1 /media/FLASH-DRIVE

where /dev/sdb1 is the address assigned to the flash drive (if she only has one hard drive, the first flash drive plugged into the machine would probably be /dev/sdb1; if she had hard drives, it would be /dev/sdc1, etc. You may just need to guess until you hit the right one).

After that, she could open up her flash drive in the graphical file browser by typing:

sudo nautilus /media/FLASH-DRIVE

and be able to drag-and-drop her files into it.


It's also possible that her problems with Gnome are specific to her user account, not a system-wide problem. In that case, creating a new user account would probably solve the problem. You can create a new user in Gnome using the System>Administration>Users and Groups utility, or from the command-line by typing:

sudo adduser newuser

where newuser is the name of the new user account.

You might want to have her create a new account, and then see if she can log into normal Gnome under it. If so, fixing her real account would probably be as simple as renaming her ~/.gnome and ~/.gnome2 folders in her home directory.

January 5th, 2009, 05:25 AM
Thanks for the response.

1. When trying to open the users & groups utility, she received an error that stated the configuration couldn't be read. We changed to a different user account on the system, thinking it may be an account-specific problem, but that account wouldn't load either.

2. We got the flash drive mounted, and could read from it, but could not write to it. We tried changing permissions and ownership of /media/flashdrive to no avail. We tried copying from the GUI as well as in the terminal. When attempting to copy the entire home directory with:

sudo cp -al /home/username /media/flashdrive

It gave numerous "could not create link" errors, and something in reference to cross-filesystem link problems. So then we tried using fdisk to wipe the jump drive to make it ext3, but fdisk gave errors on it as well (can't remember exactly what they were, this was all done over the phone).

Any other suggestions?

January 5th, 2009, 05:30 AM
tell her to disable desktop effects before doing something drastic like reinstalling.
That's a symptom of the video card not "liking compiz", she may have to remove it all together if disabling effects don't work

January 5th, 2009, 05:54 AM
That behavior with the flash drive is strange.

She might have better luck if she booted to a live CD and tried copying her files in that environment. On the live CD, the flash drive would probably auto-mount, but she might need to mount her Ubuntu hard drive manually. It sounds like you know enough to be able to walk her through this, however.

She might also be able to burn her files to CD, but I don't know how viable an option that would be; maybe she has too much data.

Finally, if you can get her machine online, she could use rsync or scp to copy her files to a remote computer, or you could mount a remote file system over sftp so that she could just drag-and-drop her data onto it. The reason that she can't currently get a connection may be simply that Failsafe Gnome doesn's auto-connect; if that's the case, it might work to run NetworkManager manually by typing:

sudo NetworkManager

Or you could run:

sudo dhclient eth0

to connect her ethernet interface. If she only has a wireless connection, you could also get that up using the command-line, although it would be more work; I can give you links with instructions if necessary.