PDA

View Full Version : [ubuntu] the shift button is not working



heroidi
January 3rd, 2009, 11:26 AM
when i press the shift button and want to write something with big characters it doesnot work help plz.

heroidi
January 3rd, 2009, 01:40 PM
help plz im going mad :(:(:(

nemilar
January 3rd, 2009, 02:05 PM
Can you post the output of the following commands:


locale



setxkbmap -print



also try the keyboard on another computer, to make sure it isn't a hardware problem!

heroidi
January 3rd, 2009, 02:12 PM
heroid@heroid-desktop:~$ locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=
heroid@heroid-desktop:~$ setxkbmap -print
xkb_keymap {
xkb_keycodes { include "evdev+aliases(qwerty)" };
xkb_types { include "complete" };
xkb_compat { include "complete" };
xkb_symbols { include "pc+us+inet(evdev)" };
xkb_geometry { include "pc(pc105)" };
};
heroid@heroid-desktop:~$

here man

nemilar
January 3rd, 2009, 02:21 PM
Does the caps lock key work to produce capitals? If not, does the light for the caps lock key work?

do all your other keys work correctly?

It looks like your keyboard setup is correct...standard 105 key setup. Unless you are using some non-standard, non-american keyboard...??


Can you check that the shift key works on another computer?

nemilar
January 3rd, 2009, 02:23 PM
Can you also try dropping into a TTY and seeing if shift works there?

Key combination control+alt+F4 will give you a TTY

control+alt+F7 to come back to X.

heroidi
January 3rd, 2009, 02:33 PM
the caps lock works and the shift key works for other functions when i press shift and super for drawing fire or something else mabye ive lost the binding how can i bind shift for using it for writing something?

heroidi
January 3rd, 2009, 02:38 PM
shift works on tty

heroidi
January 3rd, 2009, 03:07 PM
help plzzzzzzzzzzzzzzzzzz

heroidi
January 3rd, 2009, 03:46 PM
help plz somebody

heroidi
January 3rd, 2009, 05:03 PM
I think i lost my key binding how can i bring it back to deafult plz helppppppp

nemilar
January 3rd, 2009, 06:04 PM
It sounds like you are experiencing this bug:

https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/246081


The last post suggests this fix:
1. Go the System > Preferences > CompizConfig Settings Manager. If you don't have CompizConfig Settings Manager installed, you do so by opening a terminal and typing "sudo apt-get install compizconfig-settings-manager".
2. Launch the CompizConfig Settings Manager. On the left column there is a "Preferences" button. Click it.
3.Click on the "Reset to Defaults"

heroidi
January 3rd, 2009, 07:23 PM
i need something else man it does not work still

nemilar
January 3rd, 2009, 07:36 PM
Disable compiz and see if it works...