View Full Version : [ubuntu] "eth0 device not ready" when trying to share internet

January 3rd, 2009, 07:20 AM
My desktop has Ubuntu Intrepid installed and it connects through wireless to get online. My old laptop however also has Ubuntu Intrepid installed, but unfortunately I don't have a wireless card for it quite yet.

So I plugged in my laptop to my desktop through an Ethernet cable and when I select the share internet connection in Firestarter I get

"Failed to start the firewall
The device eth0 is not ready."

How do I share my internet connection to my laptop through my desktop?

January 3rd, 2009, 05:01 PM

January 3rd, 2009, 05:10 PM
"Ok, so the "eth0 not ready" issue was solved by assigning a static IP to it."

Instead of takeing guesses on how to do this I'm just going to ask, because I'm not too sure on how to go about doing that.

January 4th, 2009, 06:18 PM
Dunno if the static address bug in NM got solved, but here (http://ubuntuforums.org/showthread.php?t=974382) is a workaround. Save removing NM for a last resort.

January 4th, 2009, 06:37 PM
what about when wlan0 wont work?

January 5th, 2009, 04:51 PM
same thing. use static ip