PDA

View Full Version : [xfce] Right-click doesn't work in Thunar unless holding button



coldwind777
January 3rd, 2009, 05:15 AM
For some reason, when I right-click an icon (file or directory) in Thunar, the context menu only appears for as long as I'm holding the button. I have to right-click and hold instead of just right-clicking. It doesn't do this if I click on empty space, any of the icons in the side pane or in any other programs. It started doing this recently, and I've tried uninstalling and reinstalling. Anybody have this problem or have any ideas on how I should go about fixing it?

siafok
March 24th, 2009, 11:21 PM
I have the problem too. Have you found any solution?

siafok
March 24th, 2009, 11:58 PM
OK. I've found it. There is a bug in Thunar when you got in themes/.../gtkrc or in ~/gtk-2.0 entry: "gtk-menu-popup-delay =". I've only tried values from 0-2 with no success and finally I've comment it out so I dont know if with higher values right click menu in Thunar works.

jorgebadad
February 25th, 2012, 03:42 AM
Thanks, very, very thanks siafok !

I am running fluxbox with thunar and I had the same problem; I was unistalling fluxbox, but I found your tip; I commented the "gtk-menu-popup-delay =" in gtkrc file (in ~/.themes/theme_directory) and now I fixed the bug.

Thank you very much!