View Full Version : [ubuntu] Problem Installing in Terminal

January 1st, 2009, 10:51 PM
So I'm officially a day into Ubuntu, just enough time for me to be able to grind my teeth at its complexity, slam my fists at its seemingly impossible installation dilemmas, and then calm myself down upon realizing how much, aside from the problems I am having with it, I actually love it.

Now, onto my problems. One of my biggest road blocks came when I slid in the first disk of Return of the King and Totem wouldn't play it. I began on a quest to try and fix this problem, none of which worked. I've come across a few DVD playing programs (kaffiene, xine, vlc), but I can't seem to get any of them installed and working without some kind of error message in the terminal.

My latest attempt was to install Kaffiene. I popped open the terminal and followed the instructions the official download page (http://kaffeine.kde.org/?q=download) gave me for installing it.

So I type "apt-get install kaffeine" into my home directory.

I get this error:

E: Could not open lock file /var/lib/dpkg/lock - open (13 Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

Every time I try to install something I get an error message very similar to that. My first request is that someone would please help me with this issue, my second request is that someone would fill me in on the best program to install for DVD playing.

Sorry, I'm sure you guys get hounded by noobs all day long. All help is appreciated, thanks.

January 1st, 2009, 11:00 PM
put sudo infront of it

sudo apt-get install

or you can use synaptic package manager in the system>administration

January 1st, 2009, 11:03 PM
you might also need to install the restricted extras

sudo apt-get install ubuntu-restricted-extras

January 1st, 2009, 11:05 PM
Oh. I knew it would turn out to be something simple.
I'm using the Synaptic Package Manager, but can you tell me why it gave me this error just for future reference.

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package kaffiene

I tried to install restricted extras and got this:

E: Could not get lock /var/lib/dpkg/lock - open (11 Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

January 1st, 2009, 11:06 PM
kaffeine was spelled wrong

January 1st, 2009, 11:10 PM
Oh, yep. That would create a problem...I feel dumb.
What about the restricted extras problem? (Edited into my previous reply.)

January 1st, 2009, 11:12 PM
Close the Synaptic Package Manager before running the install command from the terminal. Only one instance of it can run at a time, weather you run it from the terminal or from the GUI. :)

January 1st, 2009, 11:13 PM
Close the Synaptic Package Manager before running the install command from the terminal. Only one instance of it can run at a time, weather you run it from the terminal or from the GUI. :)


good point!!

January 1st, 2009, 11:23 PM
Okay, I installed the restricted extras and Kaffeine successfully, but when I try to play my DVD in the program I just get a black screen. Any idea why?

January 1st, 2009, 11:30 PM
Have you installed libdvdcss2? See http://medibuntu.org/

January 1st, 2009, 11:32 PM
I had a similar problem. If playing multimedia is a primary use, like it was for me, it was a lot easier to install Linux Mint, which is basically Ubuntu with the stuff you are trying to install. It just plays the DVDs and other stuff right out of the box. Ubuntu is great also, I have them both on my machine.


January 1st, 2009, 11:35 PM
Well, I'll look into that.
Now I have a whole other problem. It seems to be one thing after another...
When I opened Kaffeine to play the DVD it froze, so I shut down the computer. When it came back on I got this message upon opening Synaptic Package Manager.

E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report.

January 1st, 2009, 11:37 PM
Open a terminal and run "sudo dpkg --configure -a"

January 1st, 2009, 11:47 PM

sudo apt-get install libdvdread3 libxine1-ffmpeg totem-xine build-essential debhelper fakeroot

sudo /usr/share/doc/libdvdread3/install-css.sh

January 2nd, 2009, 12:27 AM
Wow, Okay it finally works.
This is one complicated OS. Haha.
It's going to take some getting used to. Thanks for all the help guys.