PDA

View Full Version : [ubuntu] 8.10 won't install - disk controller problem?



jeffsilverm
January 1st, 2009, 07:23 PM
I am having troubles installing 8.10. I carefully checked the MD5 checksum and did a read after write when I burned my CD. I had the same troubles 8.04. The system would take about 20 minutes and kick me into initramfs and busybox. I can still run 7.10 just fine. I also tried using all_generic_ide and rootdelay=130 in the boot string, no joy. I tried irqpoll and all_generic_ide and changing the connector from the black one at the end of the cable to the gray one in the middle (I have an 80 conductor cable). Changing the cable changes the IDE drive from primary master to primary slave, but otherwise has no effect. If I get rid of the quiet directive in the boot command string, then I get the following message over and over:

kjournald starting commit interval 5 seconds
EXT3-FS: mounted file systemn with ordered data mode

I read somewhere that this was a bug in a 8.04 and I was hoping that it would be fixed in 8.10.

I have an IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06) AMD Athlon(tm) XP 1800+ 512 MBytes of RAM.

This is a generic IDE controller with "old fashioned" IDE disk drives. What other information would be helpful?

Thank you

Jeff Silverman
jeffsilverm at gmail dot c0m

axel_2078
February 16th, 2009, 10:35 AM
I'd be interested to get more info on this as well. I've been trying to install Ubuntu 8.10 32-bit on my laptop without success. It's an older laptop with an Intel P-4 2.4 Ghz proc and 512 MB memory. The Ubuntu 8.10 cd will not load no matter which option I select at the main screen. I just get the Ubuntu splash screen and that's it. When I try to boot without the quiet splash option, I see a ton of "buffer i/o error on device sr0" messages. While googling, I noticed that other people who had this same problem claimed they either solved it by burning another disk at a slower speed (which I already tried - didn't work) or by swapping out their cd/dvd-rom drive with a newer one that could handle larger buffers. My dvd-rom drive works just fine in Windows and I've actually loaded other linux distros on this same laptop before, so I'm not sure what's keeping me from loading Ubuntu 8.10 on it.

Edit: I just tried this again and used the F6 option and then edited the boot line. I removed the quiet splash part and replaced it with noacpi and after that, it booted. I still got tons of the sr0 errors, but it kept right on rolling through the boot process until it actually loaded the desktop. Maybe this will help someone else out.

up4it
February 18th, 2009, 11:36 AM
Thanks Axel. Your fix also worked for me! :cool: I tried everything to get it installed before that but it failed every time.

The fix is:-

Edit: I just tried this again and used the F6 option and then edited the boot line. I removed the quiet splash part and replaced it with noacpi and after that, it booted. I still got tons of the sr0 errors, but it kept right on rolling through the boot process until it actually loaded the desktop. Maybe this will help someone else out.

Note: You need to edit the command line text at the bottom of the screen after you press F6 key once NOT select the option on the pop-up window which appears when you press F6 twice.