View Full Version : [ubuntu] No sound on Compaq Presario CQ40-130TU (ubuntu 8.10)

December 31st, 2008, 04:54 PM
Dear all,
My laptop's speaker not working after installed ubuntu 8.10.
Any one please help.:confused:

January 2nd, 2009, 01:22 AM
I looked on HP's web site and couldn't figure out what the sound chip is, sorry. If you post the output from sudo lspci -v you may get more advice. In the meantime, if you run alsamixer, does it show more than one device? And are they all turned on?

January 8th, 2009, 03:24 PM
Dear Sir,
This is Liew again. My laptop still not working. Please help!!!

January 8th, 2009, 03:39 PM
post the o/p of lspci|grep Audio

January 24th, 2009, 06:55 PM
Hi. I'm facing the same problem too. The output of my lspci|grep Audio is:

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

What shall i do? TQ in advance.

January 27th, 2009, 07:49 PM
I'm using Compaq Presario CQ40-126AU but the sound is no problem here after installing ubuntu 8.10. I think the sound card is same.

January 29th, 2009, 05:31 AM
try adding this "options snd-hda-intel enable_msi=1" in the /etc/modprobe.d/alsa-base . works for me..:D

February 10th, 2009, 04:56 PM
Hey thanks, it perfectly worked. By the way, what does that line do?

March 17th, 2009, 09:37 AM
Thank you so much :) I faced the same problem and now I can solve it already :)