View Full Version : [all variants] mount fedora ext3 gives "wrong fs type, bad option, bad superblock"

December 30th, 2008, 09:37 PM
This is the command I am running:

sudo mount -t ext3 -o defaults /dev/sdb2 /media/sdb

And I get:

mount: wrong fs type, bad option, bad superblock on /dev/sdb2,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

Suggetions I have seen are to install nfs-common and portmap (no effect here), or running various fdisk like utils to "fix" the broken filesystem. There shouldn't be anything broken about the filesystem, it is an old Fedora drive, and I can boot to it just fine if I plug it in alone. I'd just like to get some old files off it.

Anything I should try?

December 30th, 2008, 10:46 PM
Did you setup LVM on that drive?

December 30th, 2008, 11:46 PM
Are you sure you are trying to mount the correct partition? How about posting:

sudo fdisk -lu
And please identify your partitions.

December 31st, 2008, 04:49 PM
Ha! Turns out it was LVM across two drives, and I was trying to mount them one at a time.

Thanks for the hint.

Instructions here worked for me to get them mounted:


December 31st, 2008, 07:48 PM
Glad you got it sorted. For anyone else bumping into this thread, with a standard LVM volume you can enable it with

sudo vgchange -ay VOLUME_NAME

where VOLUME_NAME is what you see under /dev - e.g. you may have a structure such as /dev/VOLUME_NAME/home, /dev/VOLUME_NAME/boot etc.

You can then mount the individual sections as usual e.g.

sudo mount /dev/VOLUME_NAME/home /media/MOUNT_PT