PDA

View Full Version : [ubuntu] No internet connection - Destination Host Unreachable



cattanica
December 29th, 2008, 12:07 PM
Hi,

I just changed my PCI ethernet card and I'm having problems with the connection: none of the applications requiring internet (including firefox, thunderbird, ftp, ssh, aptitude) works.

Here's the output from the ifconfig and route commands:


camilla@camilla-laptop:~$ ifconfig

eth4 Link encap:Ethernet HWaddr 00:06:29:15:74:6c
inet addr:192.168.1.2 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::206:29ff:fe15:746c/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:36 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:4586 (4.5 KB)
Interrupt:10 Base address:0x3000


camilla@camilla-laptop:~$ route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 * 255.255.255.0 U 0 0 0 eth4
link-local * 255.255.0.0 U 1000 0 0 eth4
default 192.168.1.1 0.0.0.0 UG 0 0 0 eth4


(I've added the defaulf one by doing: route add -net 0.0.0.0 gw 192.168.1.1 eth4).
When I ping I get the following:


camilla@camilla-laptop:~$ sudo ping -c3 192.168.1.1

PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
64 bytes from 192.168.1.1: icmp_seq=1 ttl=64 time=0.045 ms
64 bytes from 192.168.1.1: icmp_seq=2 ttl=64 time=0.042 ms
64 bytes from 192.168.1.1: icmp_seq=3 ttl=64 time=0.045 ms

--- 192.168.1.1 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1002ms
rtt min/avg/max/mdev = 0.724/2.382/4.040/1.658 ms


camilla@camilla-laptop:~$ ping -c3 62.108.1.66

PING 62.108.1.66 (62.108.1.66) 56(84) bytes of data.
From 192.168.1.2 icmp_seq=1 Destination Host Unreachable
From 192.168.1.2 icmp_seq=2 Destination Host Unreachable
From 192.168.1.2 icmp_seq=3 Destination Host Unreachable

--- 62.108.1.66 ping statistics ---
3 packets transmitted, 0 received, +3 errors, 100% packet loss, time 1999ms
, pipe 3

I've read lots of threads about similar problems, but found no solution...any help would be very appreciated!!

Thanks a lot :), Camilla

wmoore
December 29th, 2008, 12:14 PM
Is 62.108.1.66 your own IP? In that case I'm not surprised with your result. Try the following and post the result up here.

traceroute 209.85.171.104and
traceroute www.google.com

cattanica
December 29th, 2008, 01:43 PM
that's what I got:


camilla@camilla-laptop:$ traceroute 209.85.171.104
traceroute to 209.85.171.104 (209.85.171.104), 30 hops max, 40 byte packets
1 192.168.1.1 (192.168.1.1) 0.752 ms !N 0.666 ms !N 0.549 ms !N

camilla@camilla-laptop:$ traceroute www.google.com
traceroute: unknown host www.google.com


Thanx for your help!

wmoore
December 29th, 2008, 01:59 PM
Weird - the first traceroute command only returned a single line then stopped? The second result shows that DNS wasn't working but this could be the symptom of something else. Please run the following command and paste results here:

cat /etc/resolv.conf

You are obviously posting this from another machine - is this on the same network using the same gateway?

cattanica
December 29th, 2008, 02:36 PM
Yes, traceroute only gives me one line and then stops...


camilla@camilla-laptop:$ cat /etc/resolv.conf
#Generated by NetworkManager
camilla@camilla-laptop:$

The machine I'm writing from uses the same netowork and gateway. I also tried my laptop on different networks and different modems, with the same behaviour.

wmoore
December 29th, 2008, 02:41 PM
Yes, traceroute only gives me one line and then stops...


camilla@camilla-laptop:$ cat /etc/resolv.conf
#Generated by NetworkManager
camilla@camilla-laptop:$The machine I'm writing from uses the same netowork and gateway. I also tried my laptop on different networks and different modems, with the same behaviour.OK, you have no DNS settings for starters. Edit /etc/resolv.conf using gedit, nano or whatever your favourite text editor is :)
Assuming your router is also your DNS server, add the following line:
nameserver 192.168.1.1 and try again.

cattanica
December 29th, 2008, 04:06 PM
Ok, I added the line and I can see it with cat /etc/resolv.conf.

However, traceroute 209.85.171.104 still gives me the same output.
If I ping 209.85.171.104 I get the message "Destination Net Unreachable" rather then "Destination Host Unreachable" (not sure if this helps...).

wmoore
December 29th, 2008, 10:51 PM
Doing some Googling, I find lots of people with this issue in Ubuntu but not many solutions offered .... One possible solution I saw was to boot with the kernel option
pci=noacpi.

cattanica
December 31st, 2008, 10:08 AM
I know, I've been Googling a lot too before posting this.
I tried to boot with pci=noacpi already, no luck. Arghhh...](*,)
Thanks anyway :)