View Full Version : [kubuntu] 8.10 Intrepid + Firefox - symbol lookup error: /usr/lib/libgtk-x11-2.0.so.0

December 29th, 2008, 12:05 AM
I was using Ubuntu Hardy 8.04LTS with Gnome desktop until this week without any issues, but then messed something up - don't ask, long story, but the upshot is that I am now on Kubuntu Intrepid 8.10 with KDE 4.1.2 (I think). I only ever used Gnome before, but really like the glossy feel of KDE :)

I did an Alternate CD upgrade to Intrepid - I had to really as I'm away from home and my big external HDD to back up my stuff to. So I should know better than to do an upgrade rather than a fresh full instll, but I needed a working system.

So I've had numerous problems with it - the most annoying being this one:

Launching Firefox 3, Pidgin, and numerous other apps I used to use fine on Gnome, start but then fail with this kinda error (when run from konsole):

xxx@xxxxxxxxxx:/$ firefox
/usr/lib/firefox-3.0.5/firefox: symbol lookup error: /usr/lib/libgtk-x11-2.0.so.0: undefined symbol: gdk_threads_add_idle

I've spent most of today trying to find a solution and altho there seems to be a few similar issues I can't seem to fix it...

I've tried:
- sudo apt-get --reinstall install libgtk2.0-0
- sudo ldconfig
- sudo apt-get remove --purge firefox-3.0
then moving the .mozilla folder with all my old config files and bookmarks etc elsewhere
then sudo apt-get install firefox-3.0
and a few other sudo apt-get commands but nothing has worked and it's doing my head in :)

Any suggestions please?