PDA

View Full Version : [ubuntu] [SOLVED] Cant connect to the internet



Kryptonianeren
December 28th, 2008, 08:51 PM
I cant connect to my internet when I am behind a router. I am running duelboot ubuntu 8.10 and vista both are 64 bit. vista have no problems, and if I start ubuntu and put my cable direct in my modem it all works fine.

Anyone got a good answer why it dont work when I am behind my router??

albinootje
December 28th, 2008, 09:21 PM
I cant connect to my internet when I am behind a router. I am running duelboot ubuntu 8.10 and vista both are 64 bit. vista have no problems, and if I start ubuntu and put my cable direct in my modem it all works fine.

Anyone got a good answer why it dont work when I am behind my router??

Can you post the output of :


ifconfig -a
route -n
cat /etc/resolv.conf
ping -c3 62.108.1.66

Kryptonianeren
December 28th, 2008, 11:20 PM
When I do that I get this

alex@krypto:~$ ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:1f:d0:20:5d:e0
UP BROADCAST RUNNING MULTICAST MTU:64 Metric:1
RX packets:4 errors:0 dropped:421653560 overruns:0 frame:0
TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1300 (1.3 KB) TX bytes:1857 (1.8 KB)
Interrupt:251 Base address:0x4000

eth1 Link encap:Ethernet HWaddr 00:1f:d0:20:5d:e2
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:423240922 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:250 Base address:0x6000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:2 errors:0 dropped:0 overruns:0 frame:0
TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:100 (100.0 B) TX bytes:100 (100.0 B)

pan0 Link encap:Ethernet HWaddr da:46:b6:10:9e:82
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

alex@krypto:~$ route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
alex@krypto:~$ cat /etc/resolv.conf
# Generated by NetworkManager
nameserver 192.168.25.1
alex@krypto:~$ ping -c3 62.108.1.66
connect: Network is unreachable

I just cant see what is wrong, when I look at my connection info I can see that I get a ip, and on my other windows pc I can go in on my router and it can see my ubuntu ip address, but still no connection to the net

albinootje
December 28th, 2008, 11:50 PM
I just cant see what is wrong, when I look at my connection info I can see that I get a ip, and on my other windows pc I can go in on my router and it can see my ubuntu ip address, but still no connection to the net

Can you try the following in a terminal on the Ubuntu machine :


sudo dhclient
ping -c 62.108.1.65


If that works, then it looks like it's a Network Manager problem, you might want to see whether wicd gives you better results instead :
http://wicd.sf.net

If wicd then works for you, file a bug-report about Network Manager.

janusm
December 29th, 2008, 12:12 AM
Get a Netgear WPN511 card, see my entry:

CAN connect with Netgear wpn511

My computer is a IBM T30 and running Ubuntu Hardy Heron, 8.04.
Here is what I did after trying for quite some time to get my wireless card to work. I found this on some Linux website, and it WORKS !!!!!!
In my T30, I had to remove my internal WiFi card.

1. Plugged in my netgear WPN511 card. It started flashing 2 light alternately.
2. (Applications, Assessories, Terminal) Typed in:
sudo iwconfig atho essid <your ssid here>
sudo iwconfig ath0 key <your hex key here> restricted
sudo iwpriv ath0 mode 3
sudo iwpriv ath0 authmode 2
sudo dhclient ath0
3. After the second iwconfig, both lights started blinking together.
4. I could login to my website.

I had another Netgear card, WG511U and that works too.

At the moment I have to write these instructions everything time the computer is booted. I have a question, where do I put these instructions to automatically when booted it is included.

-Jan

albinootje
December 29th, 2008, 12:25 AM
2. (Applications, Assessories, Terminal) Typed in:
sudo iwconfig atho essid <your ssid here>

At the moment I have to write these instructions everything time the computer is booted. I have a question, where do I put these instructions to automatically when booted it is included.

/etc/rc.local is an option.
First read carefully what is already written in that file.

Kryptonianeren
December 29th, 2008, 11:25 AM
When running sudo dhclient:


dennis@dupont:~$ ping -c 62.108.1.65
Usage: ping [-LRUbdfnqrvVaA] [-c count] [-i interval] [-w deadline]
[-p pattern] [-s packetsize] [-t ttl] [-I interface or address]
[-M mtu discovery hint] [-S sndbuf]
[ -T timestamp option ] [ -Q tos ] [hop1 ...] destination
dennis@dupont:~$ sudo dhclient
[sudo] password for dennis:
Internet Systems Consortium DHCP Client V3.1.1
Copyright 2004-2008 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

wmaster0: unknown hardware address type 801
piSIOCSIFADDR: No buffer space available
nwmaster0: unknown hardware address type 801
Listening on LPF/pan0/42:4f:78:96:d7:fb
Sending on LPF/pan0/42:4f:78:96:d7:fb
Listening on LPF/wlan0/00:15:af:0a:e2:b7
Sending on LPF/wlan0/00:15:af:0a:e2:b7
Listening on LPF/wmaster0/
Sending on LPF/wmaster0/
Listening on LPF/eth1/00:18:f3:cd:77:f0
Sending on LPF/eth1/00:18:f3:cd:77:f0
Listening on LPF/eth0/00:18:f3:cd:8b:0a
Sending on LPF/eth0/00:18:f3:cd:8b:0a
Sending on Socket/fallback
DHCPDISCOVER on pan0 to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on wmaster0 to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 4
send_packet: Message too long
DHCPDISCOVER on pan0 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on wmaster0 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 21
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 4
send_packet: Message too long
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 5
send_packet: Message too long
DHCPDISCOVER on pan0 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on wmaster0 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 13
send_packet: Message too long
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 12
DHCPDISCOVER on pan0 to 255.255.255.255 port 67 interval 14
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on wmaster0 to 255.255.255.255 port 67 interval 17
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 21
send_packet: Message too long
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on pan0 to 255.255.255.255 port 67 interval 20
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on wmaster0 to 255.255.255.255 port 67 interval 16
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 14
send_packet: Message too long
DHCPDISCOVER on pan0 to 255.255.255.255 port 67 interval 2
No DHCPOFFERS received.
No working leases in persistent database - sleeping.

ruchi
December 29th, 2008, 01:33 PM
When running sudo dhclient:


dennis@dupont:~$ ping -c 62.108.1.65
Usage: ping [-LRUbdfnqrvVaA] [-c count] [-i interval] [-w deadline]
[-p pattern] [-s packetsize] [-t ttl] [-I interface or address]
[-M mtu discovery hint] [-S sndbuf]
[ -T timestamp option ] [ -Q tos ] [hop1 ...] destination
dennis@dupont:~$ sudo dhclient
[sudo] password for dennis:
Internet Systems Consortium DHCP Client V3.1.1
Copyright 2004-2008 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

wmaster0: unknown hardware address type 801
piSIOCSIFADDR: No buffer space available
nwmaster0: unknown hardware address type 801
Listening on LPF/pan0/42:4f:78:96:d7:fb
Sending on LPF/pan0/42:4f:78:96:d7:fb
Listening on LPF/wlan0/00:15:af:0a:e2:b7
Sending on LPF/wlan0/00:15:af:0a:e2:b7
Listening on LPF/wmaster0/
Sending on LPF/wmaster0/
Listening on LPF/eth1/00:18:f3:cd:77:f0
Sending on LPF/eth1/00:18:f3:cd:77:f0
Listening on LPF/eth0/00:18:f3:cd:8b:0a
Sending on LPF/eth0/00:18:f3:cd:8b:0a
Sending on Socket/fallback
DHCPDISCOVER on pan0 to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on wmaster0 to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 4
send_packet: Message too long
DHCPDISCOVER on pan0 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on wmaster0 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 21
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 4
send_packet: Message too long
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 5
send_packet: Message too long
DHCPDISCOVER on pan0 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on wmaster0 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 13
send_packet: Message too long
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 12
DHCPDISCOVER on pan0 to 255.255.255.255 port 67 interval 14
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on wmaster0 to 255.255.255.255 port 67 interval 17
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 21
send_packet: Message too long
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on pan0 to 255.255.255.255 port 67 interval 20
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on wmaster0 to 255.255.255.255 port 67 interval 16
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 14
send_packet: Message too long
DHCPDISCOVER on pan0 to 255.255.255.255 port 67 interval 2
No DHCPOFFERS received.
No working leases in persistent database - sleeping.

I am confused.this problem out of my mind sorry

albinootje
December 29th, 2008, 04:36 PM
When running sudo dhclient:
---cut---
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 14
send_packet: Message too long


See :
https://bugs.launchpad.net/ubuntu/+source/dhcp3/+bug/274069
https://bugs.launchpad.net/ubuntu/+source/dhcp/+bug/294046

One person there talks about a possible misconfigured router.

rjmatthews62
December 29th, 2008, 05:18 PM
I've found a bug where 8.10 doesn't like nameservers on the local network. Sometimes.

If you can see you router, find out the address of your ISPs name server.
Add it into /etc/resolv.conf
ie: nameserver yourdns
See if this improves things,

NOTE: NetworkManager will try to overwrite it next time you boot.
Possible solution:
http://ubuntuforums.org/showthread.php?t=581029

Kryptonianeren
December 30th, 2008, 01:08 PM
Fixed it it was Network Manager that made some <beep>.. thx for you help.