PDA

View Full Version : [ubuntu] my keyboard has serious problems PLEASE HELP ME



Herstjori
December 27th, 2008, 05:58 AM
Can anyone help me PLEASE?

My keyboard has stopped working completely on the internet and in everthing else the number pad doesn't work!! I am writing this is Openoffice. I use Ubuntu 8.10 and Firefox 3.0.4

Numberpad has stopped working altogether and all I get from it is a Bold Red Box.

I have unplugged the keyboard and plugged it back in.
I have entered my keyboard manufacturer and model type.
I can't change the layout from USA - but that is correct anyway

bodhi.zazen
December 27th, 2008, 06:59 AM
Sounds like a hard ware problem, do you have a different key board you can test ?

Is it by chance wireless and does it need a new battery (just hoping) ?

Herstjori
December 27th, 2008, 09:05 AM
Thanks Bodhi.zazen for replying.

Key board is ps2 and it is the same one I have been using for about 2 years. It works fine in sometimes other times the T and the O keys are the main ones that seem to drop off (as well as the numberpad and arrow keys of course).

This has been happening for about 5 days now before then no problems - I am also having other issues with folders taking up to 5 minutes to open and when I close them they are all not responding with the force quit option coming up?!?!?!

SonnHalter
December 27th, 2008, 09:23 AM
you sure you have number lock on when using the num pad?

have you updated lately?

Herstjori
December 27th, 2008, 11:06 AM
Haha yes the num lock is on and even if it wasn't it wouldn't explain the arrow keys not working.

Yes update everyday or when the update manager requests.

Thanks for help though!

Bucky Ball
December 27th, 2008, 11:12 AM
Try booting into recovery and watch for errors. Fix packages and X conf. You can also fix any packages in Synaptics. The random behaviour of your problem leads me to think this may not have anything to do with your keyboard setup. When the keyboard goes wonky, is this also when things start to slowdown and other random things start happening (not just the keyboard)?

nucleuskore
December 27th, 2008, 12:11 PM
Looks like a pure keyboard problem. These membrane boards are not very robust, and if you do a lot of typing, they tend to go off in a year or two.

HereInOz
December 27th, 2008, 12:21 PM
Just try a new keyboard first. That way you will know whether it is keyboard, other hardware, or software. No point in chasing shadows, so replace the keyboard first up.

This will sound strange, but some PS2 keyboards have a very marginal connection with the PS2 socket - the pins are only just long enough to connect, and if the keyboard is not plugged in firmly, strange things happen.

If the keyboard is one of those which are USB/PS2, with the little green adaptor on it, plug it into a USB port - you could have developed a troublesome PS2 port.

You must verify the integrity of your keyboard before chasing software issues.

gigaSproule
December 27th, 2008, 12:30 PM
I had this problem before with one of my keyboards. I used to keep installing the driver for it, but after a couple of days only the keys 1-4 would work, and all the other keys plus the media buttons would just stop. I think you'll just have to buy another keyboard.

bodhi.zazen
December 27th, 2008, 06:10 PM
I agree with HereInOz, we need to determine if this is a hardware or software issue and IMO easiest is to try an alternate keyboard as a first step.

Herstjori
December 28th, 2008, 02:35 PM
Thanks everyone. Have tried a new keyboard and it worked fine. However after about 4 hours of use the same thing started happening.

albinootje
December 28th, 2008, 02:40 PM
My keyboard has stopped working completely on the internet and in everthing else the number pad doesn't work!! I am writing this is Openoffice. I use Ubuntu 8.10 and Firefox 3.0.4


I suggest booting from a 8.04 or 8.10 installation cdrom, and choose the live session.
Then check the differences, and report back.

theozzlives
December 28th, 2008, 02:47 PM
Time for a keyboard, you can get one cheap at Wal-Mart.

Herstjori
June 24th, 2009, 09:39 AM
Ok so I am now onto my third keyboard same problem.

Is it possible to reload the keyboard settings or something

I am using generic 105

Albinootje as I no longer have the installation disc (I lent it to a friend so they could start using limewire and they never gave it back and I moved far away from them) I will download it over night during the offpeak hours and burn it off and try the live session tomorrow.