PDA

View Full Version : [ubuntu] 8.10 wired network startup problem



neo37
December 26th, 2008, 04:33 PM
I have a static ethernet configured on eth0:

iface eth0 inet static
address 192.168.0.5
netmask 255.255.255.0
gateway 192.168.0.1
auto eth0

When I boot the system, chances are big that connectivity is not there.
The interface is up and running according to ifconfig, but
a ping to an IP address on the same net fails.

I have to restart the interface a couple of times (ifup/ifdown, or enable/disable with the panel applet), and suddenly, the connectivity is there. Sometimes, it takes just one restart, sometimes five, and sometimes even the connectivity is there right after the boot. Once the interface works, it remains working till shutdown.
Any ideas what may cause this problem?

This is on a ca. 2Yr Dell Vostro 200 desktop, and the problem is there since I upgraded from 7.04 to 8.10 (upgrade utility, going through 7.10 and 8.04). With 7.04, the interface worked always and immediately. There's nothing in the log/dmesg about a problem with the interface.

I already changed cable and switchport, and I tried booting with irqpoll to omit potential irq conflicts, but it does not change. The interface is an intel pro:
00:19.0 Ethernet controller: Intel Corporation 82562V-2 10/100 Network Connection (rev 02)

No matter whether connectivity is ok or not yet ok, the log shows on each restart:
[ 3869.924756] 0000:00:19.0: eth0: Link is Up 100 Mbps Full Duplex, Flow Control: RX/TX
[ 3869.924763] 0000:00:19.0: eth0: 10/100 speed: disabling TSO

I could write an init.d script that loops through ifup/ifdown's till a ping succeeds, but maybe there is a better fix?

Thanks for any suggestions...

dragos_iliescu_2005
December 26th, 2008, 05:13 PM
I will suggest two possible solving way:
1. set the eth0 to use dhcp, reboot and read the connection parameters that you can use for have a static ip.
2. remove from config the line "auto eth0"

neo37
January 7th, 2009, 02:07 PM
Thanks,

but when I remove the "auto eth0", it doesn't start the interface at all.

I tried with dhcp, there the situation is similar, sometimes it works and sometimes not. I don't see which connection parameters I could carry over to the static config.

Anyhow, I wrote the script that does loop through ifdown and ifup till a ping to the gateway succeeds, and added it to /etc/rc.local.
Ugly hack, but at least there is a working network connection whenever the system is switched on.