View Full Version : [ubuntu] [SOLVED] Acer Aspire One Netbook, No Wirless

December 26th, 2008, 12:14 AM
I just installed intrpid and got rid of windows on this netbook. Wirless won't work and I've been sifting through "wireless problems with edgy/breezy" and I'm getting sick of it. Does anyone have any updated info on how to get wireless on my netbook?

December 26th, 2008, 07:47 PM
Should I be getting madwifi?

December 26th, 2008, 07:56 PM
I have the same problem.

The wireless card is recognised and working with my Linpus Linux Lite which came on the machine, but is not recognised by default with my Ubuntu installation (it's dual boot currently).

Any help would be greatly appreciated.

@doubad: please email me at clampstand@gmail.com if you find a fix, or post it here. I shall be looking into it with more detail when I get home later tonight, or tomorrow - will report back.

Mod please do not edit to exclude my email address, I do not care for spam with that account.

December 26th, 2008, 09:50 PM
Have it fixed now.

Download this wireless driver: http://snapshots.madwifi-project.org/madwifi-hal-

Move it to your Documents folder and extract.

Open up a Terminal (Applications > Accessories > Terminal)


cd /home/username/Documents/madwifi-hal-

Press enter. Then type:


Will take a couple of minutes, wait until you get the correct prompt again.

Then type:

sudo make install

Let it do it's stuff, then:

modprobe ath_pci

Restart laptop, then when you click your networks icon you should get that beautiful list of wireless networks to connect to.

Hope this helps,

- Jake.

NB: how do you like the Aspire One so far? I like it, pretty damn neat, need to get my compiz working though =\

December 27th, 2008, 06:23 AM
It's so nice to come home after a long day and someone has solved the problem for you. Thank you so much! You've fixed it.

I love my little aspire, this is my first laptop. I've never seen the point of owning a laptop until these netbooks came out.

Thanks again!

January 28th, 2009, 12:59 AM

I have just installed Ubuntu on my acer one netbook, but the wireless does not work, so after pulling my hairout i came acroos this website and this help, and i was so excited until i came across this issue. I have have followed the instructions but it does not seem to work for for me when i type the first command it says no such file or directory, This is what i did.

downloaded http://snapshots.madwifi-project.org...0081204.tar.gz
on a usb stick, unziped it and had a file clled madwifi-hal- I then placed the usb in my acer netbook usb slot and copied it in Ubuntu's places then selected Documents.
then loaded Terminal and typed cd /home/username/Documents/madwifi-hal- then press enter
it says No such file or directory.
I have tried with space after cd and with no space after cd but i still get no joy.

I am very new to this so please help me i bought a external dvd drive so i can install ubuntu on it as it only comes with Acer version on linux, Please help as i do not want to install acer linux on it .

Thank you


January 28th, 2009, 01:31 AM
I hope you remembered to replace the "username" part of it with your username.

But, what I did is rename the folder that comes from the tar.gz file to something easier.
So mine looked like something like this
cd /home/darryl/Documents/madwifi
then I followed the instructions above.

January 31st, 2009, 04:44 PM
Please have a look at this post again, as i am having some problem.

I am really sorry to send you a private email, but i need help.

thank you

No problem; if you want quicker replies feel free to email me at jb.dude@gmail.com

So you have an Acer Aspire One, and the wireless is not working? have you followed the commands provided in the post?

The first command is
cd /home/username/Documents/madwifi-hal-

You need to replace where it says "username" with your own username. This is the one you use to log in. If you don't know it you can find out by going to System > Preferences > About Me, and then in the top right it will tell you your username.

Hope this helps,


I responded to your pm.

Also, the purchase of an external CD/DVD drive was unnecessary, as Ubuntu can be installed from a USB drive.