PDA

View Full Version : [ubuntu] 8.04 hardy heron display problem



hoboboot
December 25th, 2008, 09:07 PM
i just installed hardy heron on my laptop, i have a gateway mx3210, which has a via unichrome pro IGP vn800 VIDEO CARD... i currently dont have it online because its got a broadcomm wifi card, i bet the ethernet works but i havent tried yet, in 7.10 ethernet worked off the hop i believe. thats not the issue right now though, this is more important: my biggest and first issue i'd like to deal with (so i can even begin to deal with other issues) is that, i cannot see my whole desktop when i've logged in, obviously theres no driver for my vid card setup or whatever, i JUST installed 8.04 yesterday... so, what i get though, its as if i have an extra big resolution, but my lcd screen is only showing the top left corner of the desktop, so for example when i maximize a window, it runs right off the page... this makes it difficult to actually get things done... in 7.10 off just the livecd i could change resolutions just fine... but in hardy it just screws up at every option, resolution is currently OFF, if i change it to a resolution i desire, its overlapping graphx and tottally screwey i can see 4 cursors and 4x the number of "ok" / "cancel" buttons, and whatnot... basically before i can get at anything else, i need to solve my display resolution issue and make the desktop fit my screen. it is a widescreen... but as i said 7.10 live cd worked alright... also i have edited the applications menus to have other:graphics and screens or whatever linked in the appz->other> menu, but when i try to open that it prompts for password at the edge of the screen and then nothing happens, or the window is lower than my screen is showing of the destop, you know? should i be seeing a window after that password privledges prompt? of what i do see by default, its a big good picture, my laptops actual screen probably has 1280x768 pixels like, on the screen i think max display... in 7.10 it did 1024x768 and that was livable, i could see the entire desktop and use the system without missing the bottom and right sides of the os...what i have now is no good, and i cant even get it to go right if i try 800x600 cause it screws right up if i try ANY res basically...then i cant set it back to 'off' which is what the dropdown menu said, before i dropped it down to try from the list of resolutions, none of which worked...basically after trying that its graphically screwed but i can still manage to read some of the distorted stuff on screen, and get the dropdown menu open again and manage to read a diff res and select it, however once i change that from OFF once, OFF is not there again to choose from, it changes them too without the timer that will change them back if you dont click keep these settings, there isnt even a revert your settings automatically timer! so its just screwed res... luckily for me i shut down the computer (properly in screwed graphx mode by clicking on shut down (which i could see 4 times on the screen, everything was overlapped and layers misplaced... and lucky for me when i rebooted ubuntu logged in, it was not in the screweed graphx mode... im glad that it didnt save but i wonder why it didnt save too... but if it did i would be even more scewed. please shed some light on my situation here if you can? is this because i need to install the driver or the display? im sorry this is as long as it is, thanks for reading my problem, i've seen the experts in these forums seem to request troubleshooter post etc/x11/xorg.conf so i've posted it below: PLEASE CAN SOMEBODY HELP ME MAKE MY DISPLAY IN 8.04 WORK RIGHT? and thanks in advance for your time it means alot to me.





# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "ca"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizEdgeScroll" "0"
EndSection

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Synaptics Touchpad"
EndSection

didac
December 27th, 2008, 12:13 PM
First try in a terminal:


sudo displayconfig-gtk

Select openchrome as graphics driver, or alternatively, via. Reboot and start changing display resolutions. Work from small ones. If it doesn't work, you can add the line:


Driver "vesa"

to your xorg.conf in the section Display, after that line -- Section Display, I mean.