PDA

View Full Version : [ubuntu] How to set my screen res to 1680x1050



Heeter
December 23rd, 2008, 06:32 AM
Hi all

I have an acer AL2216W 22"lcd.

I am trying to figure out how to set my screen res to 1680x1050. Looks like it is set at 12x10.

It is a fresh install of UbuntuStudio 8.10

I am using an intel D945 onboard graphics, with the visual effects enabled.

Thanks

Heeter

Heeter
December 24th, 2008, 12:27 AM
Bump.....

Any all help would be great.

the 1680x1050 resolution is not available in the dropdown menu.

Thanks

Heeter

fdmille
December 24th, 2008, 02:48 AM
You need to modify your xorg.conf file in the directory /etc/X11. I'm using a Acer X223W monitor in 1680 x 1050 through the DVI cable and it works great!

Post a copy of your xorg.conf file if you can't get it to work.

Here is mine:

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Monitor"
Identifier "Configured Monitor"
Vendorname "Generic LCD Display"
Modelname "LCD Panel 1680x1050"
Horizsync 30 - 81
Vertrefresh 56.0 - 75.0
modeline "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
modeline "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
modeline "1280x768@60" 80.14 1280 1344 1480 1680 768 769 772 795 -hsync +vsync
modeline "1280x720@60" 74.48 1280 1336 1472 1664 720 721 724 746 -hsync +vsync
modeline "1280x800@60" 83.46 1280 1344 1480 1680 800 801 804 828 -hsync +vsync
modeline "1440x900@60" 106.47 1440 1520 1672 1904 900 901 904 932 -hsync +vsync
modeline "1600x1024@60" 136.36 1600 1704 1872 2144 1024 1025 1028 1060 -hsync +vsync
modeline "1680x1050@60" 147.14 1680 1784 1968 2256 1050 1051 1054 1087 -hsync +vsync
Gamma 1.0

EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
SubSection "Display"
Virtual 1680 1050
EndSubSection
EndSection

Section "Device"
Identifier "Configured Video Device"
EndSection

Heeter
December 24th, 2008, 03:51 AM
This is weird........

My /etc/X11/xorg.conf file is empty. There is nothing written on it.

Help?


Heeter

taurus
December 24th, 2008, 03:53 AM
Does your intel D945 onboard graphics even support that resolution?

Heeter
December 24th, 2008, 03:59 AM
Yes it does, easily.

Have no issues with my other Linux OS's


Heeter

Heeter
December 24th, 2008, 08:33 AM
You need to modify your xorg.conf file in the directory /etc/X11. I'm using a Acer X223W monitor in 1680 x 1050 through the DVI cable and it works great!

Post a copy of your xorg.conf file if you can't get it to work.

Here is mine:

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Monitor"
Identifier "Configured Monitor"
Vendorname "Generic LCD Display"
Modelname "LCD Panel 1680x1050"
Horizsync 30 - 81
Vertrefresh 56.0 - 75.0
modeline "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
modeline "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
modeline "1280x768@60" 80.14 1280 1344 1480 1680 768 769 772 795 -hsync +vsync
modeline "1280x720@60" 74.48 1280 1336 1472 1664 720 721 724 746 -hsync +vsync
modeline "1280x800@60" 83.46 1280 1344 1480 1680 800 801 804 828 -hsync +vsync
modeline "1440x900@60" 106.47 1440 1520 1672 1904 900 901 904 932 -hsync +vsync
modeline "1600x1024@60" 136.36 1600 1704 1872 2144 1024 1025 1028 1060 -hsync +vsync
modeline "1680x1050@60" 147.14 1680 1784 1968 2256 1050 1051 1054 1087 -hsync +vsync
Gamma 1.0

EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
SubSection "Display"
Virtual 1680 1050
EndSubSection
EndSection

Section "Device"
Identifier "Configured Video Device"
EndSection

Hey, I dropped your xorg.conf into my setup, now I have 1680x1050 on my screen res list, but when I select it, the picture only shows up on about 2/3's of my screen. I now have a huge black bar across the bottom and the right side. I am able to mouse over the black bars.

Help?

Heeter

Seks
December 24th, 2008, 09:01 AM
I have the same monitor as you with 1680x1050 :)

It was quite a headache, but you don't need to mess with modelines and junk. Here's my xorg.conf, I'm pretty sure the 'Option "ModeValidation" "NoMaxPClkCheck"' under 'screen' is what fixes it:




Section "Monitor"
Identifier "Monitor0"
Vendorname "Acer"
Modelname "Acer AL2216W"
Horizsync 30.0-82.0
Vertrefresh 56.0-76.0
Gamma 1.0
Option "DPMS"
Option "ConnectedMonitor" "DFP"
Option "ExactModeTimingsDVI" "true"
Option "PreferredMode" "1680x1050@60"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
Option "ModeValidation" "NoMaxPClkCheck"
DefaultDepth 24
EndSection

Section "Module"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
Load "v4l"
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

Section "ServerLayout"
Identifier "Layout0"
screen 0 "Screen0" 0 0
EndSection

Section "Device"
Identifier "Device0"
Boardname "NVIDIA GeForce FX (generic)"
Option "NvAGP""1"
Screen 0
Vendorname "NVIDIA"
Option "MonitorLayout" "TDMS"
Option "ModeValidation" "NoDFPNativeResolutionCheck"
Driver "nvidia"
EndSection

Heeter
December 24th, 2008, 09:06 AM
Awesome, Thanks a million,

Will try right away!!!!

BTW, what vid card do you use?


Heeter

Lupusceleri
December 24th, 2008, 11:13 PM
Going to add some to this thread, as I just bought a 20 inch monitor with 1680x1050 resolution myself.

Using parts from Seks' xorg.conf I could get my new Samsung T200 monitor to work with the right resolution.

But I still can't seem to get the thing to use a refresh rate over 51 Hz (my screen supports up to 85 Hz or so it says on the internet, I'd settle for 60 though).

Here's my xorg.conf, I just commented lines I didn't know for sure what they did:


# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Monitor"
Identifier "Configured Monitor"
Vendorname "Samsung"
Modelname "Samsung T200"
Horizsync 30.0-81.0
Vertrefresh 50.0-85.0
# Gamma 1.0
# Option "DPMS"
# Option "ConnectedMonitor" "DFP"
# Option "ExactModeTimingsDVI" "true"
Option "PreferredMode" "1680x1050@85"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24
Option "ModeValidation" "NoMaxPClkCheck"
# SubSection "Display"
# Depth 24
# Modes "1280x1024"
# EndSubSection
EndSection

Section "Module"
Load "glx"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"
EndSection

mystyc
January 3rd, 2009, 09:51 PM
i just gt one of those monitors as well and geetting to the native setting is almost impossible if not totally impossible, but you are saying that you only have the VGA input. I find that weird though cause i have one and it has both VGA and DVI inputs. but i do know that one way of geting the native is to have the DVI section of the monitor in use/// and yes the monitor is great but the refresh rate is a bit crappy

Heeter
January 3rd, 2009, 11:17 PM
No, I said I can't use my DVI, only my VGA connector. My monitor does have both too.


I cannot get my DVI to work at all. It works fine with my VGA @ 54 Hz. Everything looks just fine.


Heeter

trustintrance
February 12th, 2009, 01:12 AM
I'm having similar issues getting my x223w to the native refresh rate as well. Is it safe to run the monitor at 1650 x 1080 at only 50hz instead of the native 60hz? Will this cause any damage to the monitor?