View Full Version : [ubuntu] Can't Download Updates

December 21st, 2008, 06:54 PM
I haven't done updates for a while. Yesterday I ran updates with my Ubunto 8.04 machine. I had about 80 updates and it took a long time. I'm down to my last 8, but every time the machine attempts to get updates I get the following message:

W: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/s/shadow/login_4.0.18.2-1ubuntu2.1_i386.deb
404 Not Found

I have internet access and all the other updates worked. I'm working as administrator. What is happening?


December 21st, 2008, 07:04 PM
The package may have been updated and it's trying to get the old one that's not there anymore. Try

and enter

sudo apt-get update then close the terminal after it finishes and returns you to the prompt and go to
System>Administration>Synaptic Package Manager
click on reload then Mark All Upgrades then Apply
That should take care of it.

December 21st, 2008, 07:59 PM
You may need to change your server in Software Sources.

December 22nd, 2008, 12:11 AM
Thank-you. Problem solved.